NvBufSurfTransform failed with error -3 while converting buffer

  1. can you try with the same source with mine? namely using ffmpeg to make a video. using 10 urls, the app will hang when using 2928M GPU memory.
  2. can you use the deepsream officail sample deepstream-app to reproduce this issue? noticing your pipeline can be tested by deepstream-app. if you can still reproduce this issue, please share the video url and configuration file. Thanks!

I think I have made myself very clear that this issue can only be triggered with 50 sources because 10 sources are not enough to produce sufficient objects so the problem won’t happen.And you met a hang problem because I didn’t bother handling how it end, so you can just ignore it.

I could’t reproduce this issue with deepstream-app and that was why I had to offer extra code to test. It’s a little troublesome to modify deepstream-app’s source code to add source dynamiclly. I ran some more tests and found out that if I call addSource before pipeline is ready then the issue will not happen either.

I think there maybe some differences among our tests ,so I posted my config files and engine files below. Could you check if there are the same with yours? And did you run the test code in nvcr.io/nvidia/deepstream:6.2-devel container?
config_infer_primary.txt (4.0 KB)
config_tracker_NvDeepSORT.yml (6.3 KB)
mars-small128.uff (10.7 MB)

please refer to runtime_source_add_delete for how to add source dynamically. there

yes, there are the same.

I tested in nvcr.io/nvidia/deepstream:6.2-triton, which has the same deepstream version.

Could you try to run the test code in nvcr.io/nvidia/deepstream:6.2-devel container and see what will happen? I don’t know if there are any differences between them.I’ll try it in nvcr.io/nvidia/deepstream:6.2-triton

I tried nvcr.io/nvidia/deepstream:6.2-triton and still got “gstnvtracker: NvBufSurfTransform failed with error -3”. That’s really weird.Could you give me an email address so I can send you my test video files?I don’t know what else I can do now.

please share it by the forum email.

Have you received the video file? I sent it to you by the forum message.

yes, but the output.mp4 shows a static picture, it is the same with the video made by ffmpeg.

Yes,that’s exactly the video file I used to produce the issue.So I don’t understand why it can’t be reproduced on your environment.Maybe I should try some other way to reproduce it later.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

using the new file output.mp4 shared by email, I still can’t reproduce “NvBufSurfTransform failed with error -3” on T4+ ds6.2.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.