NVCC path for .deps files in Visual Studio 2012


Using CDUA Toolkit 6.0 with Visual Studio 2012 on Windows 8.1 64-bit. I am compiling a static library containing CUDA code for use by other parts of our software. Everything is working correctly except that .deps files corresponding to .cu files are being placed in a strange location. I have tried to outline the directory structure involved below:

Before compilation:
                  /         \
                wsp         src
                /             \
             shared          cuda  
              /                 \
         MyCUDALib             image
            /                     \
      MyCUDALib.vcxproj        operations

After compilation:
                 /           \
                wsp          src
               /   \           \
           shared  src         cuda  
             /       \           \
         MyCUDALib   cuda        image
           /           \           \
  MyCUDALib.vcxproj   image      operations
                         \           \
                     operations   MyCUDAFile.cu

I’m not sure if there’s something set incorrectly in my compiler options or if the structure we’re using is confusing the compiler but I can’t figure out how to get the .deps files to go somewhere sensible. Can anyone offer any ideas? Is this a bug? Do I even need to generate the .deps files and if not how can I turn them off?


Hi, I have the same problem here. Did you found any solution/workaround ?