nvdisplay : how to turn off screen sleeping

Hello,

I am currently working on the deployment of a qt application on jetsonTX2 (connect tech orbitty motherboard) with a graphical user interface.

I have installed l4t32.2.1 (ubuntu 18.04) on the TX2. My application start automatically at boot with a rc.local script. To achieve this I uninstall all the graphical environment such as lightdm and the desktop environment. Everything works in console mode.

Everything works well except that after 10 min the screen goes to sleep. I tried this command :

setterm -powerdown 0

but it does not change anything. I also tried to stop these services

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target suspend-then-hibernate.target

but it does not work either.

Here is the result of the dmesg command just after the screen goes to sleep and once it comes out to sleep.

[  613.459925] tegradc 15210000.nvdisplay: blank - powerdown
[  613.512005] extcon-disp-state external-connection:disp-state: cable 47 state 0
[  613.512008] Extcon AUX1(HDMI) disable
[  613.534349] tegra_nvdisp_handle_pd_disable: Powergated Head2 pd
[  613.534446] tegra_nvdisp_handle_pd_disable: Powergated Head1 pd
[  613.535276] tegra_nvdisp_handle_pd_disable: Powergated Head0 pd
[  630.476058] tegradc 15210000.nvdisplay: unblank
[  630.476878] tegra_nvdisp_handle_pd_enable: Unpowergated Head0 pd
[  630.476970] tegra_nvdisp_handle_pd_enable: Unpowergated Head1 pd
[  630.477052] tegra_nvdisp_handle_pd_enable: Unpowergated Head2 pd
[  630.478364] Parent Clock set for DC plld2
[  630.481267] tegradc 15210000.nvdisplay: hdmi: tmds rate:71000K prod-setting:prod_c_hdmi_54m_111m
[  630.482498] tegradc 15210000.nvdisplay: hdmi: get RGB quant from EDID.
[  630.482504] tegradc 15210000.nvdisplay: hdmi: get YCC quant from EDID.
[  630.519005] extcon-disp-state external-connection:disp-state: cable 47 state 1
[  630.519009] Extcon AUX1(HDMI) enable
[  630.521507] tegradc 15210000.nvdisplay: unblank

I think there is something with nvdisplay but I don’t know how to configure this to stop the screen goes to sleep. Any help would be appreciated.

thanks.

Hi,

Actually this should be nothing to do with nvdisplay driver but user space configuration.

Please refer to this thread:
https://devtalk.nvidia.com/default/topic/1043733/jetson-tx2/how-to-disable-screen-off-and-screen-lock-on-jetpack3-1-of-tx2-device/

Hi,

I tried the following commands but without success :

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type nothing
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 0
gsettings set org.gnome.desktop.session idle-delay 0	
gsettings set org.gnome.desktop.screensaver.lock-enabled false

I don’t have the “sleep-display-ac” and the “sleep-display-battery” key in “org.gnome.settings-daemon.plugins.power”

Here is the keys I have in org.gnome.settings-daemon.plugins.power :

gsettings get org.gnome.settings-daemon.plugins.power
active                                   idle-brightness                          percentage-critical                      sleep-inactive-battery-type
ambient-enabled                          idle-dim                                 percentage-low                           time-action
button-hibernate                         lid-close-ac-action                      power-button-action                      time-critical
button-power                             lid-close-battery-action                 priority                                 time-low
button-sleep                             lid-close-suspend-with-external-monitor  sleep-inactive-ac-timeout                use-time-for-policy
button-suspend                           notify-perhaps-recall                    sleep-inactive-ac-type
critical-battery-action                  percentage-action                        sleep-inactive-battery-timeout

Is there another parameter that I need to change?

Thanks