NVdrmvideosink failure with TX2 in Jetpack4.6.2

Hi Sir,

We did the preview through “NVdrmvideosink” near 10 secs and then stop the preview. At that moment, the screen turned to a black screen.
As we tested, it always failed (happened to the black screen) the 1st time.
We have tried this in Jetpack4.4, and NO black screen happened.

The steps are as below:

  1. init camera
  2. preview (via NVdrmvideosink) 10sec
  3. stop preview
  4. BLACK SCREEN HAPPENED at the 1st time.

Test Environment:
-Jetson TX2
-Jetpack 4.6.2

Thanks.

Hi,
Do you observe the issue with connecting to all TVs. Or it is specific to connecting to certain TV?

Hi,
It happenes on the HDMI and DSI monitor.

Hi,
We try the command and don’t hit the issue:

$ gst-launch-1.0 videotestsrc num-buffers=300 is-live=1 ! nvvidconv ! 'video/x-raw(memory:NVMM),format=I420' ! nvdrmvideosink

Please try the command in your setup and see if it woroks.

Hi,
We tried this command on the TX2 development kit and our system.
The normal screen can last near 10sec and then turn to a black screen. It still failed our 1st trial test.
As we see the black screen, we plug and unplug the HDMI connector, the normal screen comes back.

$ gst-launch-1.0 videotestsrc num-buffers=300 is-live=1 ! nvvidconv ! ‘video/x-raw(memory:NVMM),format=I420’ ! nvdrmvideosink plane-id=1 conn-id=0

Hi,
It runs for 10 seconds due to the setting num-buffers=300. If you need the pipeline to keep running, can remove the setting.

We don’t observe any issue on TX2 + TV in 1080p60 mode. Please check if there is deviation between your setup and ours.

Hi,

As mentioned, the normal screen can last running 10sec, and our expectation is we can open and close the window with the normal screen repeatedly. But our test results and problem is the black screen happened and hanged after 10secs as the first-time test was finished and didn’t go back to the normal screen.

Hi,
Seems like you don’t disable GUI system. For running nvdrmvideosink, the GUI system has to be disabled first.

Hi DaneLLL

Thanks for your message

Sorry, but I don’t know what do they mean by disabling GUI system.

We were using JetPack 4.4 than switch to Jet pack 4.6.2 and having issue as describe above

Please advice
Thanks

Hi,
Please look at
Jetson Linux API Reference: 08_video_dec_drm (Direct Rendering Manager)

HAve to execute the steps before running DRM:

Ensure the Ubuntu desktop is disabled:
$ sudo systemctl stop gdm
$ sudo loginctl terminate-seat seat0

From the screenshot it looks like you don’t disable Ubuntu desktop.

Hi DaneLLL

Thanks for your reply and suggestion

We can’t run our app without X11

So suggested solution will not work for us.

We are using X11 in Jetpack 4.4 and it is working for us

Please advice

Thanks
Waseem

Hi @waseem.ahmed

It is a normal one that you need to disable X11 to run the DRM usecase. These two may compete the resources of the framebuffer window.

Thus, better disabling X11 first. Or you can comment on what you want to run here, why X11 is must-have to you.

Hi,
With X11, please use nv3dsink or nveglglessink. The nvdrmvideosink is designed for non-GUI environment.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.