Nvdsmetamux gstnvdsmetamux.cpp:1005:gst_nvdsmetamux_aggregate:<infer_bin_muxer> push error

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version Docker 6.3
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)
When I run the command ./apps/deepstream-parallel-infer/deepstream-parallel-infer -c configs/apps/bodypose_yolo_lpr/source4_1080p_dec_parallel_infer.yml with the repo deepstream_parallel_inference_app, I met the error:

0:00:04.092711495  6753 0x563508a48b60 ERROR            nvdsmetamux gstnvdsmetamux.cpp:1005:gst_nvdsmetamux_aggregate:<infer_bin_muxer> push error

Modify: I modified the configuration file sink0 : enbale: 0 → 1
How could I do to solve it ?

Is a monitor connected to your device and what’s the specific model of your GPU?

I run it on host, and I had solved it by using docker. But it still had an error:

The sink0 is used to display the video. Is a monitor connected to your host? How do you start a docker?

Yes, I want to show display the video on the screen and I start the docker by running the follow command :

docker run --gpus all -it --cap-add=SYS_ADMIN --net=host --privileged -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.3 nvcr.io/nvidia/deepstream:6.3-triton-multiarch

Initially, I was using MobaXterm to remotely manipulate the host, and then, I ran it directly on the host and it still reported this error

DeepStream doesn’t support this display mode. If you want to display video, you need a monitor device on the host. Then you can display the video remotely through NoMachine or other similar software.

Yeah, I finally run it on the host which have a monitor, but the error still happened.

You need to run the xhost + before starting the docker.

Thanks for your reply, I had solved this probleam. And I want to modify the deepstream-app.cpp, where can I find it? /opt/nvidia/deepstream/deepstream/sources/apps/sample_apps/deepstream-app

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

Yes. And you can also find some source code in the opt\nvidia\deepstream\deepstream\sources\apps\apps-common path. If you have any other issues, you can file a new topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.