[NVFlare] instance:xxx : exception_occured debugging

Hi everyone,

Sorry for sticking with Clara Train, but couldn’t find forum dedicated to NVFlare. I have been playing around with NVFlare and rewrote the sample code to fit my needs. However, once I start the app and server says that Server training has been started, after a while I will get an exception saying “instance: xxx : exception_occured”. I can’t find any python exception on either clients, server or admin-client. As the code isn’t open source, I guess something is catching an error and just propagating such message up through the stack.

Can anyone from NVFlare dev team please hint me on what kind of issue could be behind/whether different logging settings wouldn’t show me an exception? I am using the default ones from the demo.

Thank you,
Regards Ladi

Where did you see this “exception_occured” message? Is it on the server / client, or the admin? Which version of NVFlare are you using?

Is it possible for you to upload your log, or sample application codes for us to trouble shoot? Or you can turn on the log to DEBUG level. Then you will be able see more logging information on the server / client log.

Hi,

Thank you for your answer.

  1. The exception occured on the clients and message was visible on the admin client. Just substitute client name instead of xxx in the title and you will get the message visible

  2. I used the original tf logger, just changed logger_root’s level to DEBUG. I couldn’t find examples online, so if you can advise me on how to get more granular debug output, I would be glad.

If I can’t get any more information, I will post a code.

Thank you one more time :)

You can set the NVFlare log to DEBUG level by changing the client startup/log.config to the following:

[logger_root]
level=DEBUG