NVGST pipeline error

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU)**T4
• DeepStream Version5.0
• JetPack Version (valid for Jetson only)
• TensorRT Version7.0
**• NVIDIA GPU Driver Version (valid for GPU only)**440
On executing
gst-launch-1.0 filesrc location=…/…/samples/streams/sample_1080p_h264.mp4 ! m.sink_0 nvstreammux name=m batch-size=1 batched-push-timeout=40000 width=1920 height=1080 live-source=TRUE ! nvvideoconvert ! nvinfer name=nvinfer1 config-file-path=config_infer_primary_yoloV3_tiny.txt model-engine-file=model_b1_gpu0_fp32.engine ! nvtracker tracker-width=640 tracker-height=368 ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so enable-batch-process=1 ! nvinfer name=nvinfer2 process-mode=secondary infer-on-gie-id=1 infer-on-class-ids=“0:” batch-size=16 config-file-path=/home/ubuntu/Desktop/resnet_50_test/config_infer_secondary_vehicletypes.txt model-engine-file=/home/ubuntu/Desktop/resnet_50_test/trainval.caffemodel_b16_gpu0_fp32.engine ! nvdsosd process-mode=1 ! filesink location=a.mp4

Following is shown on terminal. I am using ssh access so I dont want to use nveglessink element. There are many errors, kindly do help.
Warn: ‘threshold’ parameter has been deprecated. Use ‘pre-cluster-threshold’ instead.
Setting pipeline to PAUSED …
0:00:00.480803051 4626 0x564969918560 ERROR nvinfer gstnvinfer.cpp:596:gst_nvinfer_logger: NvDsInferContext[UID 0]: Error in NvDsInferContextImpl::initialize() <nvdsinfer_context_impl.cpp:971> [UID = 0]: Unique ID not set
0:00:00.480862257 4626 0x564969918560 WARN nvinfer gstnvinfer.cpp:781:gst_nvinfer_start: error: Failed to create NvDsInferContext instance
0:00:00.480871135 4626 0x564969918560 WARN nvinfer gstnvinfer.cpp:781:gst_nvinfer_start: error: Config file path: /home/ubuntu/Desktop/resnet_50_test/config_infer_secondary_vehicletypes.txt, NvDsInfer Error: NVDSINFER_CONFIG_FAILED
ERROR: Pipeline doesn’t want to pause.
ERROR: from element /GstPipeline:pipeline0/GstNvInfer:nvinfer2: Failed to create NvDsInferContext instance
Additional debug info:
gstnvinfer.cpp(781): gst_nvinfer_start (): /GstPipeline:pipeline0/GstNvInfer:nvinfer2:
Config file path: /home/ubuntu/Desktop/resnet_50_test/config_infer_secondary_vehicletypes.txt, NvDsInfer Error: NVDSINFER_CONFIG_FAILED
Setting pipeline to NULL …
Freeing pipeline …

Hi,

That happens since each nvinfer requires different unique-id which is only configurable on PAUSE state. So `gst-launch-1.0’ is not able to achieve this requirement.

You could use GStreamer Daemon or write a simple GStreamer application to configure unique-id properties in appropriate GStreamer state.

Regards

-Angel

1 Like