NVIDIA 310.19: glxinfo command cause X freeze with GeForce 8400M G

Hi all,

I am running Slackware-14.0 on an ASUS Z37SP. The graphics card is a GeForce 8400M G.

Both with the stock kernel (3.2.29-smp) and with the latest currently available (3.6.9), X freezes every time I run a program that uses 3D acceleration. This happens, for instance, when I run glxinfo in a terminal window or execute nvidia-settings:

  • glxinfo freezes right at the beginning
  • nvidia-settings freezes when I exit the program.
    The computer itself does not hang, but the only thing I can do after a freeze is shutdown through the power button.

Regarding the window manager, I had this problem both with KDE 4.8.5 (all 3D effects off) and with XFCE 4.10. I made my tests without a graphical login manager, starting X manually from the terminal (startx).

I tried all the 3xx versions of the NVIDIA driver, and they all have the same problem. I also tried to fiddle with the Xorg.conf settings, for instance disabling all that could be disabled, but the problem persists.

When I ran Slackware 13.37 with driver 295.33, the NVIDIA driver worked perfectly.
Currently, I am using the nouveau driver on Slackware 14.0, but its performance is poor and I would really like to resume using the NVIDIA driver.

I attach an Xorg.0.log of the latest freeze I had, which was caused by the command nvidia-bug-report.sh. I also attach the nvidia-bug-report.log.gz file that was created in that context.

Thank you very much in advance for any help you can provide. I am more than happy to run further tests, if necessary.

Cheers,
Carlo

https://dl.dropbox.com/u/23076795/Xorg.0.log
https://dl.dropbox.com/u/23076795/nvidia-bug-report.log.gz

Confirmed for 8400Mg, Debian testing, 3.7.1 kernel with liquorix patch. Bug is present in 310 and 313 versions.

Same issue here for my 8400M G.

My system is Gentoo x86 (gentoo-linux 3.0.57; xorg-server 1.11.4) on Amilo Pa 2548. The latest working version of the driver is 285.05.09.

A little supplemental, to freeze X with the nvidia-settings you should select “OpenGL/GLX info” and then do exit.

Same issue here with also a 8400M G.

Gentoo amd64 (Linux-3.7.2-zen, xorg-server-1.13.1.901, gcc-4.7.2, glibc-2.16.0), on an Asus F3SC notebook,latesk working version of nvidia-drivers was also 285.05.09. Have tried every single version since that last one.

Very much like OP, glxinfo freezes right at the beginning,nvidia-settings freezes when I exit the program (by closing the window of killing the process). Same symptoms in dmesg/Xorg.0.log.

Same issue on Archlinux x86_64 with kernel 3.7.4-1 and xorg-server 1.13.1-1 while exiting GL applications like glxgears or games. The system freezes complely too when I launch glxinfo.

Other symptoms are a temporary system freeze after performing a shutdown or a reboot action (for about 30 seconds) and no tty access (blank screen).

Same thing with 313.18-1 beta drivers.

I also tried 304.xx drivers : accessing tty is ok (after a few seconds), glxinfo run correctly, and closing GL applications generates no system freezes but X crashs instead.