[NVidia 331.38] VSync issues/Tearing in KWin with composite enabled

After the Fedora update today I get tearing when moving windows in KWin. If I torn composite off and on again several times the issue is fixed. Still a regression.
nvidia-bug-report.log.gz (204 KB)

“Fedora update” is too vague - state packages & versions. Got an update log?

The update log is /var/log/yum.log - nothing else is required.

Do you have triple buffering enabled? If you don’t you should enable it. By default, kwin does not use vsync on the NVIDIA drivers unless you have triple buffering turned on or export __GL_YIELD=“USLEEP” before kwin is started.

KWin with NVIDIA has been problematic for me since 4.11.


I reported it to the KDE bugtracker and it was merged into this thread.


Sorry for the late reply. (I thought I had email notification enabled.)

I’ll attach my yum.log. I only have these problems since KDE 4.11.6-2 and not with older KDE 4.11 versions. Turning composite off and on again works only very unreliably to fix it. What works quite good is to change the OpenGL version KDE uses. I switch it from 3.1 to 2.0 and back again. Already the first switch fixes it and it stays fixed when I switch back to 3.1.
yum.log (109 KB)