Nvidia 390.59 Virtual screen

Good evening!
Please tell me how I can determine the size of the virtual screen when the monitors are NOT connected.
At the moment I am doing this:

Section "Screen"
    ...
    Option "AllowEmptyInitialConfiguration" "true"
    Option "metamodes" "DVI-I-1: 2560x1600 +0 +1200, DP-1: 1920x1200 +320 +0"
    Subsection "Display"
        Virtual 2560 2800
    EndSubSection
Endsection

It works fine. Next, I connect 2 monitors and try to position them relative to each other not vertically (as written in metamodes in xorg.conf), but horizontally:

 xrandr --output DP-1 --mode 1920x1200 --right-of DVI-I-1 --output DVI-I-1 --mode 2560x1600

The result is:

Screen 0: minimum 8 x 8, current 4480 x 1600, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 2560x1600 + 0 + 0 (normal left inverted x axis y axis) 641mm x 401mm panning 4480x1600 + 0 + 0
   2560x1600 59.97 * +
   1920x1440 60.00
   1920x1200 59.88
   1600x1200 60.00
   1280x1024 75.02 60.02
   1280x800 59.81
   1152x864 75.00
   1024x768 75.03 60.00
   800x600 75.00 60.32
   640x480 75.00 59.94
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 connected 1920x1200 + 640 + 200 (normal left inverted x axis y axis) 518mm x 324mm panning 3840x1200 + 640 + 200 tracking 4480x1600 + 0 + 0 border 0/0/0/0
   1920x1200 59.95 * +
   1920x1080 60.00 50.00
   1680x1050 59.95
   1600x1200 60.00
   1440x900 59.89
   1400x1050 59.98
   1360x765 59.85
   1280x1024 75.02 60.02
   1280x960 60.00
   1280x720 60.00
   1200x1920 59.94
   1200x960 59.91
   1024x768 75.03 70.07 60.00
   960x1200 59.73
   800x600 75.00 72.19 60.32 56.25
   640x480 75.00 72.81 59.94

Xorg append log:

[ 33146.917] (II) NVIDIA(0): Setting mode "DVI-I-1: nvidia-auto-select @2560x1600 +0+0 {ViewPortIn=2560x1600, ViewPortOut=2560x1600+0+0}, DP-1: nvidia-auto-select @3840x1200
 +0+0 {ViewPortIn=1920x1200, ViewPortOut=1920x1200+0+0}"

Instead of the expected result (DVI-I-1 position +0+0, DP-1 position +2560+0) there is a big panning.

If xorg.conf does not define “Virtual x y”, then everything is fine, but the size of the virtual screen becomes 640x480 (which is very small)

Version X.Org X Server 1.20.1
Version NV 390.59
RHEL 7
Card: Quadro K620

Upd: a temporary fix is

xrandr --fb 2560x1600

at startup, if there are no connected monitors ( and remove Virtual Screen in xorg.conf ).
But the inadequate behavior of nvidia and the virtual screen in xorg.conf remains.