nvidia 396.54 not supported on kernel 4.19, what to do?

Hi there,

I’ve upgraded my kernel quite a few times now and without any issue. However last night the nvidia 396.54 driver kernel module failed to compile with the lastest / new 4.19 linux kernel. Not really sure why but heres the relevant logs…

What might be the issue here? Perhaps it’s too new kernel, and has not got the necessary support yet?

… yeah it seems so. I just noticed this line in the output:

That must be it. OK so is there any way to get notified, when the necessary driver support for 4.19 is added later on? Or is support never going to be added for this specific version of the nvidia driver (396.54). In which case, do I need to install something else instead? For example switch over to the new 410 driver ?

The 396 driver is not supported anymore, please upgrade to the 410 driver using the ubuntu graphics ppa to get support for new kernels.

Thanks… it worked !

Well one win at least. But the vulkan portion of 396.54.09 has not carried forward to any 400+ series drivers. I had vkd3d running with wine, using the older driver, and when I upgraded, it stopped working. Any ideas? Since I am running wine, what information would I need to provide? Running Fedora 29, with gtx 970 4gig ram.

https://pastebin.com/yPZ1tEwb

Applied the patch, installed the patched driver, built fine for dkms, but still not working with the vkd3d in wine to run dx12 apps. Any other ideas?

Don’t really know, but for vk3d (DX12 to Vulkan) the 396 driver is not necessary, it only contains a Vulkan extension useful for DXVK (DX10/11 to Vulkan). AFAIK, vk3d should run fine with the 410 driver.
If you’re using only vk3d, what errors get thrown?

One day someone will notice this crap and we will get it fixed.
Ive expected a fix on same day but they failed.

Im total upset about this, such a mega company like they are and not able to make a proper fix.

/fail

Rawfox, you’re doing this all wrong, read and learn how to do this properly from this one:
https://forums.geforce.com/default/topic/1049931/geforce-drivers/397-31-will-not-install/post/5337819/#5337819

lmao ^^
#323 made my day ^^
yarr get out the bat

For wich driver is this ?

It’s the patch for 396.54.09 to compile with kernel 4.19 for people using dxvk to get their hair beautiful.

omg, thanks for quick reply, ill try that now !!

ok generix … we need a pic of you for the “Employee of the month” photo in the office !!

That seems to be wine related as it works here pretty nice.
I suggest you ask on WineHQ: https://www.winehq.org/

OK, Wine 3.21 with wine-staging applied will run dx12 with vkd3d, but you need to compile vkd3d from source. If you visit Winehq AppDB and find WoW 8.0, you will see the how tos for building wine to run dx12. Having said that, it works to let me login and run, but crashes after about 30 minutes, because vkd3d is still a work in progress. It is moving forward, but DXVK is still the best choice for DX11 on wow. also, you do NOT need to run 396.54.09 as the 415.18 driver works with the vkd3d and does not need to be patched.