nvidia-396 low res on Ubuntu 18.04, no secondary monitor, after installing CUDA Toolkit 9.2


I think I borked my system with this but I’d like to try to resolve it prior to a reinstall.

First of all - a fresh Ubuntu 18.04 install had no problems. I installed CUDA Toolkit 10.0 to run CARLSim4, a spiking neural network simulator [1]. However, it only works with CUDA 9.2. So, I uninstalled 10.0 and installed 9.2 using the instructions at [2]. At this point the default nvidia driver (which I believe to have been 390 out-of-the-box, though could be remembering incorrectly) was switched to nvidia-396.

Upon reboot, I lost my secondary monitor and the resolution on my primary defaulted to 1024x768. I’ve tried various things online including purging and reinstalling nvidia-396 but it seems that whenever I do so the resolution goes kaput.

I’m happy to provide any and all troubleshooting steps. Attached is my nvidia-bug-report.log.gz file.

Result of running nvidia-settings:

$ nvidia-settings

ERROR: Unable to load info from any available system

Result of lspci:

$ lspci -k | grep -EA2 'VGA|3D'  
01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1080] (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd GP104 [GeForce GTX 1080]
	Kernel driver in use: nvidia

Of ubuntu-drivers devices:

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001B80sv00001458sd00003702bc03sc00i00
vendor   : NVIDIA Corporation
model    : GP104 [GeForce GTX 1080]
driver   : nvidia-driver-410 - third-party free recommended
driver   : nvidia-driver-390 - third-party free
driver   : nvidia-396 - third-party non-free
driver   : nvidia-driver-396 - third-party free
driver   : xserver-xorg-video-nouveau - distro free builtin

Kind of grasping at straws at what else to report at this moment, so will stop there for now.

Thank you in advance!

[1] http://www.socsci.uci.edu/~jkrichma/CARLsim/

[2] https://developer.nvidia.com/cuda-92-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1710&target_type=deblocal
nvidia-bug-report.log.gz (392 KB)

The layout of the nvidia-driver in Ubuntu has changed with 18.04. So mixing up packages breaks your system.

Worked like a charm, thank you! (for posterity, the driver package name is actually ‘nvidia-driver-410’)