nvidia-418 drivers can't work on Ubuntu 16.04 with eGPU (GT1080TI)

Hi,

I have some difficulties to make Nvidia-418 drivers work on my system.
I have an intel nuc mini PCs and Ankitio node with GT1080Ti. My system is ubuntu 16.04 with kernel 4.15.
My system original installed an Nvidia-390 driver which works well. But to use TensorFlow 2.0, I want to upgrade the driver to Nvidia-418. There was no error when I installed the driver. But when I reboot my computer, the screen keeps printing “bbswitch: no discrete vga device found.”

Could you please help me with what I should do?

Thanks!

Peng
nvidia-bug-report.log.gz (1.1 MB)

How did you upgrade the driver?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi, generix,

Thank you for your reply.

I tried to install it from “Software and Update” and also tried to install by using command “sudo apt install nvidia-418 nvidia-settings”. But both didn’t work.

I attached in the gz files in this post for your review.

Thank you!

Best wishes!

Peng
nvidia-bug-report.log.gz (1.1 MB)

Hi, generix,

Thank you for your reply.

I tried to install it from “Software and Update” and also tried to install by using command “sudo apt install nvidia-418 nvidia-settings”. But both didn’t work.

I attached in the gz files in this post for your review.

Thank you!

Best wishes!

Peng
nvidia-bug-report.log.gz (1.1 MB)

With 16.04, this is kind of fiddly. In general you will have to enable usage of egpus. Please try creating a file /etc/X11/xorg.conf.d/10-nvidia-egpu.conf with contents

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration" "true"
    Option "AllowExternalGpus" "true"
EndSection

Hi, generix,

Thank you for your reply.
I tried to create the file as you suggested. But it still didn’t work. It looks the file did’t affect the xorg.conf generated by the system. I attached the xorg.conf file and the bug-report in the post for your review.

Thanks!

Best wishes!

Peng
nvidia-bug-report.log.gz (1.11 MB)
xorg.conf.txt (600 Bytes)

Ok, please remove that file again.
Try this:
use kernel parameter “nogpumanager” and add to the auto-created xorg.conf

Option "AllowExternalGpus" "true"

inside the nvidia device section.

1 Like

Hi, generix,

Thank you very much! It finally works!!!

Thank you!

Best wishes!

Peng

1 Like