Nvidia 440.82 - Failed to Register Device

Somewhere along the line, I lost the ability to use my Quadro P2000 on Arch Linux:

uname -a
Linux singularity 5.6.11-arch1-1 #1 SMP PREEMPT Wed, 06 
May 2020 17:32:37 +0000 x86_64 GNU/Linux

I’ve attached nvidia-bug-report.log

dmesg output:
$ dmesg | grep -i nvidia
[ 17.169598] input: HDA NVidia HDMI/DP,pcm=3 as
/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input17
[ 17.169677] input: HDA NVidia HDMI/DP,pcm=7 as
/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input18
[ 17.169878] input: HDA NVidia HDMI/DP,pcm=8 as
/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input19
[ 17.169924] input: HDA NVidia HDMI/DP,pcm=9 as
/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input20
[ 17.169964] input: HDA NVidia HDMI/DP,pcm=10 as
/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input21
[ 17.170005] input: HDA NVidia HDMI/DP,pcm=11 as
/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input22
[ 17.170043] input: HDA NVidia HDMI/DP,pcm=12 as
/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input23
[ 18.235258] nvidia: module license ‘NVIDIA’ taints kernel.
[ 18.277374] nvidia-nvlink: Nvlink Core is being initialized, major device number 236
[ 18.277740] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[ 18.277896] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[ 18.378497] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 440.82 Wed Apr 1 20:04:33 UTC 2020
[ 18.427075] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 440.82 Wed Apr 1
19:41:29 UTC 2020
[ 18.435074] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[ 18.492973] nvidia 0000:01:00.0: DMAR: 32bit DMA uses non-identity mapping
[ 18.493995] [drm:nv_drm_load [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000100] Failed to allocate
NvKmsKapiDevice
[ 18.494139] [drm:nv_drm_probe_devices [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000100] Failed to
register devicenvidia-bug-report.log (822.4 KB)

Please check disabling iommu, i.e. replacing the kernel parameter intel_iommu=on with iommu=off