[NVIDIA 525.85.05] Can't overclock my GPU on Wayland

I can’t overclock my NVIDIA GPU using a command like this:
nvidia-settings -a '[gpu:0]GPUMemoryTransferRateOffset[3]=2500'.
The same command works just fine on X11 session.

yoshio@localhost ~> nvidia-smi -L
GPU 0: NVIDIA GeForce GTX 1650 (UUID: GPU-55d0dd3a-7f75-890a-80b4-cfcafa22d7fa)

X11.tar.gz (1.9 KB)
inxi (3.2 KB)
nvidia-bug-report.log.gz (629.7 KB)

Had similair trouble to get it work.

I switched back to x11. Nvidia UI needs the coolbit x11 flag to load the extension, which allows overclock. Wayland options are not available AFAIK.

Found a workaround - did not tested it, yet.

"You can work around this incredibly easily. Ctrl+Alt+F2, login, and launch a minimal X session using tinywm, twm, or some other incredibly lightweight window manager. Launch GWE and you can set your overclock, power limit, fan curves, etc. Then switch back to your Wayland session. It costs pretty much zero CPU, RAM, VRAM, or GPU usage. "

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

We finally have a better solution.
The new solution can be found here: NVIDIA GPU overclocking under Wayland [guide].