Nvidia 525 grub out of memory

I am forced to boot an older linux kernel without nvidia installed

nvidia-bug-report.log.gz (148.3 KB)

cat /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


CRITICAL ERROR that prevents the USE of nvidia RTX 3090 graphics card.

Patching GRUB is the only solution if that works.

No success with any of the alternatives to patching

  • Have fewer modules,
    MODULES =dep

  • Compress initrds more,

xz compression
export XZ_OPT=‘–lzma2=preset=0,dict=8M’

  • Lower screen resolution at boot.

What’s the current size of your initrd?

grub out of memory
211497723 Dec 5 18:21 initrd.img-5.15.0-1010-nvidia

119219397 Nov 30 20:23 initrd.img-5.15.0-56-generic

That’s not really that big. I wonder if there’s a recent grub bug triggering this.
Did you already try to increase compression? The export is only for faster compression.
To reduce size further, you can omit the nvidia-uvm.ko module from initrd:

Probably this one: