Nvidia booting into blinking black screen after Starting User Manager

I have been working with my Nvidia Jetson (running ubuntu 20) for multiple months and have not recently installed any updates or drivers.

When I power on the Jetson, it will show the Nvidia screen, then the text stream, then go to a black screen. There is no blinking cursor or any text, just the screen. It will turn on and off in a slow blinking pattern. If I press Ctrl+Alt+F3, it either (this varies randomly)

  1. Opens up the terminal for a few seconds, then returns to the same startup text screen, then goes back to blinking
  2. Nothing at all

I have tried every option I’ve seen for booting into recovery mode or a GRUB menu, but nothing affects the pattern I’ve described. Because of that, I cannot try any of the solutions to somewhat similar problems that are available. I have also tried restarting several times and switching the HDMI cable and monitor.

One time, randomly and un-reproduceably, it actually opened the terminal and I was able to run commands (I’m trying to fix a problem of not being able to ssh into this computer). I restarted it later, and now I’ve back to the same problem.

The screen blinking most likely comes from the fact that xorg is crashing/stopping and systemd restarts it over and over in fast succession. Just wait for about 2 minutes depending on systemd settings for it to give up. You should then be able to log in on console and check your xorg logs/dmesg for why it fails.
This forum is mostly about the x86 drivers, you might find better help asking in the Jetson forums:
https://forums.developer.nvidia.com/c/agx-autonomous-machines/jetson-embedded-systems/70

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.