nvidia card not detected on RHEL 5.3 x86_64

I have a pair of Tyan-opteron machines with cheap 9500GT cards installed. The machines happily ran x86_64 red hat enterprise linux (actually, Scientific Linux) unp until I installed the cards and Nvidia drivers. Now, I get constant complaints about “I can’t start your x-server” and when I look in /dev for the video-cards I see nothing relevant,

[indent][root@wyandotte ~]# ls -la /dev/ | grep nv
crw-rw---- 1 root root 10, 144 Nov 6 18:04 nvram[/indent]

For what its worth, I’ve installed version x86_64-185.18.14 of the NVIDIA display driver.

Further, the xorg.conf file is similarly devoid of information that suggests the computer knows the graphics card has been plugged into the chassis.

[[indent]root@wyandotte ~]# cat /etc/X11/xorg.conf

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 1.0 (buildmeister@builder62) Wed May 27 01:58:49 PDT 2009

Xorg configuration created by system-config-display

Section “ServerLayout”
Identifier “single head configuration”
Screen 0 “Screen0” 0 0
InputDevice “Mouse0” “CorePointer”
InputDevice “Keyboard0” “CoreKeyboard”

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/input/mice"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"


Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
Option “XkbModel” “pc105”
Option “XkbLayout” “us”

Section “Monitor”

Comment all HorizSync and VertSync values to use DDC:

Identifier     "Monitor0"
ModelName      "LCD Panel 1440x900"
HorizSync       31.5 - 56.0
VertRefresh     56.0 - 65.0
Option         "dpms"


Section “Device”
Identifier “Videocard0”
Driver “nvidia”

Section “Screen”
Identifier “Screen0”
Device “Videocard0”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24

Any suggestions on how to get this all to work would be appreciated.

One one of the machines (Tyan s2912) the solutions was to select the nvidia graphics card as default in the bios. (for future reference) To do this, I had to find the motherboard manual, clear the bios memory, and then select the x16 PCI-E slot as the primary graphics adaptor. After this, things worked perfectly.