NVIDIA Corporation GP100GL [Tesla P100 PCIe 16GB] (rev a1) as virtualgl server

Hi every one
sorry for my poor English
NVIDIA Corporation GP100GL [Tesla P100 PCIe 16GB] (rev a1)

I need to use my p100 GPU as a virtual GPU for rendering display.

does this card has the capability to run OpenGL using the Nvidia free driver?

I did the things suggested for headless cards
nvidia-xconfig -a --allow-empty-initial-configuration --use-display-device=None --virtual=1920x1200 --busid PCI:134:0:0

BUT
the card is not rendering

vglconnect -e glxspheres64 192.168.3.103

VirtualGL Client 64-bit v2.5.2 (Build 20180529)
vglclient is already running on this X display and accepting unencrypted
connections on port 4242.

Pseudo-terminal will not be allocated because stdin is not a terminal.
Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0x2c0
Context is Direct
OpenGL Renderer: llvmpipe (LLVM 7.0, 256 bits)

Fri Jan 24 16:08:01 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.33.01 Driver Version: 440.33.01 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 Tesla P100-PCIE… Off | 00000000:86:00.0 Off | 0 |
| N/A 34C P0 28W / 250W | 0MiB / 16280MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+