NVIDIA: could not open the device file /dev/nvidiactl (No such file or directory).

Has anybody successfully resolved the issue:

Run cuda code and find following error: “NVIDIA: could not open the device file /dev/nvidiactl (No such file or directory).”

Tried to run the script provided by the previous note below and got the error “fix: line 9: /etc/init.d/functions: No such file or directory”.

=> “http://forums.nvidia.com/lofiversion/index.php?t52629.html

The environment is S870 with SUSE 10.

Thanks in advance!

A quick and dirty solution would be to give the program the permissions to use that device

sudo chmod a+rwx /dev/nvidiactl

Looks like your display driver has not been properly installed.

Thank you nasacort and jjtapiav!

I just checked the directory and found out that “/dev/nvidiactl” does not even exist anymore. This happened after relocating the server.

Do I have to reinstall the cuda toolkit and driver?

edit: move over to the other thread of the same name.

I got the same problem…

Cuda works fine for about a week, until I run a very long program (or maybe a infinate loop)

It seems that cuda will lock and remove the /dev/nvidiactl while running. Now, as the /dev/nvidiactl has vanished, what should I do? reinstall the cuda driver?

hi…i have a similar issue whenever i reboot my linux box. i do a chmod +777 /dev/nv* which fixes it.

I am naive in linux… Does not MAKEDEV script help?