nvidia cuda 6.5 toolkit for Linux ubuntu 14.04.1 12.04.1 12.04.2

hi
i want to as a question
on Linux ubuntu distributions there are releases and point releases like
12.04 LTS long term support they released 12.04.5 in 2014
also 14.04 has 14.04.1 point release and will continue point releases until 2019

my question is when i go to download 14.04 LTS i found in Linux it is for 12.04** and for 14.04**
does it mean it works for 12.04 and all its point releases like 12.04.1, 12.04.2, 12.04.3 , 12.04.04 12.04.5 or only 12.04 LTS and the same question for 14.04 LTS