NVIDIA CUDA [Version 9.0] Installer Failed

I am unable to install CUDA 9.0.
Error msg NVIDIA Installer failed(Visual Studio Integration failed)
(Visual Studio 2015 already installed, Windows is updated and I also tried to install CUDA 9.1 but the same issue)

Computer Spec
Graphics card: GTX 1080TI
OS: Windows10pro 64
Ram 64GB / CPU Ryzen Threadripper

Please advise

Unfortunately this does not work for me. I made sure to install this before trying to install the CUDA toolkit but the installer fails on VS integration. I tried uninstalling VS 2017 and using VS 2015 instead, and that didn’t work either.

I download visual studio 2017 installer and i select VC++ 2015.3 Tool Set (v140) from the list and installed it but the same issue. it’s so frustrating. even NVIDA people are helping!!!

Here is how I installed the toolkit 

I extract the zipped file into a folder with 7zip, then I installed the setup file with administrative privileges. Up to this point, none of them worked. But when I uncheked the visual studio integration, looks like I’ve toolkit with no visual studio support :(

Thanks 4 the tips guys !

And thanks to the Nvidia for this crappy installer btw.

Alright, I have a workaround here that allows you to install CUDA 9.1 with most VS integration.

  1. Use the VS installer to install VC++ 2015.3 Tool Set (v140)
  2. Use 7zip to extract the local CUDA installer to a folder.
  3. Run setup.exe from that folder
    • At Options, select "Custom (Advanced)"
    • Under CUDA, UNCHECK Visual Studio Integration
    • Proceed with the rest of the installation
  4. Once that's installed, go back to the folder you extracted everything to
  5. Go to 'CUDAVisualStudioIntegration' within that folder
  6. Use the two msi installers to install Nsight and NVTX
  7. Copy the files from 'extras\visual_studio_integration\MSBuildExtensions' into 'C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\BuildCustomizations' AND 'C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\BuildCustomizations'

That should get you to the point where projects will compile and run from VS.
the files in ‘CudaProjectVsWizards’ look like the templates that let you start new CUDA projects and make new CUDA files within VS. It probably wouldn’t take too much research to figure out where those go.

I’m not sure where ‘CUDAVisualStudioIntegrationExt.dll’ and ‘CUDAVisualStudioIntegration.nvi’ are meant to go.

Hi, after 3 days of headaches and realizing that nvidia doesn’t give a damn about this, I have finally found a solution. Just disable the Visual Studio support. This was the only way, trust me, they have compatibility issues with pretty much all the VS versions.

The Same issue to you, then i fixed it though followed method:

1.unintsall vs2015 & nvidia driver.
2.install vs2015 update3 in custom way, ticked add nethermost library.
3.install cuda fulled plug-in.

I don’t know why it can work suddend, just
emmmmm. remamber reboot your pc when it notified you should reboot.

Works fine if you uncheck Visual Studio Integration.

1 Like

I didn’t use Visual Studios in this new Deep Learning box I built because I’m using Python under Anaconda. Unchecking Visual Studio Integration also worked for me as well. v9.0

NVIDIA is already completely insolent, realy no user support 
 If Microsoft is your gold partner, why you can’t just make a normal installer for VisualStudio? Facepalm

You can’t find any good programmers for the company - make your product opensource and all be ok :-)
I told you many times, VisualStudio is far from the best choice, make NSIGHT for QtCreator!!!

why Nvidia makes thing really hard, or the windows always goes this way??? I am a Linux and Mac user and I simply want to run Tensorflow with GPU

I have VS2015 and am trying to install cuda 9.1 with VS integration
 fail everytime.

I have been tried installing cuda toolkit 9.0/9.1 with visualstudio 17 and installation has failed
i even tried installing using visualstudio 15 but it also failed. can anyone help me?
i was trying to install on Windows 10 .


Be absolutely SURE you have the VC++ 2015.3 loaded. I thought I did, but turns out I was incorrect (I assumed it was installed when I selected ALL the C++ options when I installed Visual Studio 2017). You will know this because the:

C:\Program Files (x86)\MSBuild\Microsoft.Cpp

folder will NOT be present (hint). Go into your Visual Studio 2017 Installer and MODIFY, then select the VC++ 2015.3 libraries in the ‘Individual Components’ section. THEN follow Kooshi’s instructions. Works like a champ, and I’m on Windows 10 Version 1709 (OS Build 16299.431).

Thanks, Kooshi!!

Thanks dotnettex! This method finally worked for me too!

I went around in circles trying everything to get the Cuda environment to install. My computer is win 10 pro, i7, x99 motherboard, 64GB DDR4 and 1080ti graphics card. I systematically tried not installing a single part to see if one was affecting installation. Turns out Visual Studio integration is not functioning correctly. That unit will not function with any version of Visual Studio from Community to Enterprise.

This should have been picked up in even basic testing, before deployment.

Anyone know the answer to this? I can get the samples to build but the templates are missing.


I have problem installing the cuda toolkit. I have run the installation but the devicequerry doesn’t go throught:
CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
→ CUDA driver version is insufficient for CUDA runtime version
Result = FAIL

Any help?

I am having the same issue. how to solve this problem.

Hi I have the same problem but I resolved this reinstalling all, I made a blog on medium

Sorry for put my link again ( i put in this on another answer).