Nvidia-driver-460 for P2200 does not show full resolution of monitors

I’ve installed new PNY P2200 in my linux workstation running Ubuntu 18.04
I did:
sudo apt purge nvidia*
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt install nvidia-driver-460
after reboot the display resolution in my computer is only 1280x 800.
My workstation is connected to two 30" Dell monitors, each 2560x1600. My previous card (XF570) and drivers (nvidia-340) recognized correctly the monitors. But not the new card/driver. Why I don’t get the correct display resolution?

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (313.2 KB)

The Dell monitor needs a dual-link DVI for full resolution, seems you’re using a passive DP2DVI adapter, this is only single-link. You will need to use an active DP to dual-link DVI converter.

OK. so I changed to new adapters: Monoprice DisplayPort 1.2a to 4K HDMI, Dual Link DVI, and VGA Passive Adapter, Black (112802)

That suppose to handle the full resolution of the Dell monitors. But i still get only 1280x800 resolution. any idea? The new nvidia-bug-report is attachednvidia-bug-report.log.gz (333.4 KB)
Thanks -Michael

Those are fake, not doing what they’re advertising

Apr 23 15:17:41 michael-office /usr/lib/gdm3/gdm-x-session[1223]: (--) NVIDIA(GPU-0): DELL3007WFPHC (DFP-1): connected
Apr 23 15:17:41 michael-office /usr/lib/gdm3/gdm-x-session[1223]: (--) NVIDIA(GPU-0): DELL3007WFPHC (DFP-1): Internal TMDS
Apr 23 15:17:41 michael-office /usr/lib/gdm3/gdm-x-session[1223]: (--) NVIDIA(GPU-0): DELL3007WFPHC (DFP-1): 165.0 MHz maximum pixel clock

Internal TMDS means those are passive, single link adapters. Active dual-link converters report ‘Internal DisplayPort’.
Even the descrption contradicts itself, ‘passive’ excludes ‘dual link’ and also 4k.

NB: the converters you need are pricey, since they’re rarely needed.

thanks. I’m waiting for the following:

I hope they’ll do the job

Worth a try. Since they’re active, those converters need a power supply. This one uses the displayport power, so YMMV. Better converters use an additional USB-connector for that.

The IOGEAR adapter fails to support DVI-DL. (I thought the DPs of the cards have some juice).
nvidia-bug-report.log.gz (307.7 KB)

but at least able to support full resolution of old dell U2412m monitors (1920x1200) with DP input. (didn’t test with 4K monitors)

According to the logs, the converters seem to work, the Dell detects DVI-DL and reports the correct resolution 2560x1600 and the nvidia driver switches to it.
Nothing visible on the monitors?

Yes. The Dell 3007WFP monitor was detected correctly as 2560x1600 but the image itself was garbled pattern of straight lines (same as I got with the passive adapter).
I tried connecting a single monitor only and using different ports but it didn’t make a difference