NVIDIA DRIVER 510 not loaded on UBUNTU 20.04 after the update, second monitor also not working


I have a problem with my NVIDIA DRIVER 510 installed on UBUNTU 20.04. After the update/actualisation and then reboot, my second monitor did not work and nvidia was not loaded, I have already tried to reinstall several times. But nvidia still not loaded. Security boot is disabled in BIOS.
Dual Boot machine with WIN 10 64bit. Dell Precission 3450. Driver 510 is recommended.

I tryed:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:17488): GLib-GObject-CRITICAL **: 12:12:35.095: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 12:12:35.098: PRIME: Requires offloading
** Message: 12:12:35.098: PRIME: is it supported? yes
** Message: 12:12:35.124: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 12:12:35.124: PRIME: on-demand mode: “1”
** Message: 12:12:35.124: PRIME: is “on-demand” mode supported? yes

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/lib/modprobe.d/nvidia-kms.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/nvidia-kms.conf:# options nvidia-drm modeset=1


lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 9bc5 (rev 05) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: NVIDIA Corporation GP107GL [Quadro P1000] (rev a1) (prog-if 00 [VGA controller])

Thank you very much for any help.

please find attached nvidia report bug:
nvidia-bug-report.log.gz (3.8 MB)

1 Like

I have exactly the same problem after the updates to Kubuntu 20.04 LTS yesterday.
I have also tried reinstalling, uninstalling, switching to the non-Nvidia driver and back. I have no blacklisted files in modprobe.d.

(base) ian@MSI:~$ nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:10480): GLib-GObject-CRITICAL **: 18:13:20.645: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 18:13:20.647: PRIME: No offloading required. Abort
** Message: 18:13:20.647: PRIME: is it supported? no
(base) ian@MSI:~$ sudo nvidia-bug-report.sh

nvidia-bug-report.log.gz (81.9 KB)

Welcome @ian.jefferson and @blahusiak to the NVIDIA developer forums!

Thank you for already sharing your bug report log files, we will have a look at them.

As Ian pointed out the Graphics/Linux forums are a great resource for solutions to similar issues like these.

Quite often Ubuntu does distribution updates that introduce incompatibilities with the recommended drivers certified as part of the distribution. In those cases the safest bet is either to roll-back for example the kernel, if it was changed, or look for an updated NVIDIA driver on our driver download pages.

Hello Thank you for your help.

I tryed this one (links bellow)- to update liquorix:


And after the reboot it works! NVIDIA is loaded and both monitor work!

Thank you very much :)

1 Like

That is great to hear!
Thanks for letting us know.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.