Nvidia driver causing system wide freezing with plasma system monitor

I have a problem with the nvidia linux proprierty driver by NVIDIA. It works normal and everything is good until I open an application called plasma-systemmonitor, which is strange because it’s just KDE-Plasma’s resource monitor and nothing much graphics related.
What happens is once I open that program - the system starts to freeze for some seconds and resumes, and it’s starts to go downhill from there. Closing the program doesn’t solve the issue and neither does restarting the X-server. The only solution once the program is opened is to restart the system.

Xorg logfile starts to put out these warnings and sometimes they are lsited as errors:
[ 802.081] (EE) event7 - HID 0b38:0010: client bug: event processing lagging behind by 24ms, your system is too slow
[ 1032.644] (EE) NVIDIA(GPU-0): WAIT (0, 8, 0x8000, 0x0000d8e4, 0x0000d8e4)
[ 1037.403] (II) event2 - PixArt USB Optical Mouse: SYN_DROPPED event - some input events have been lost.

These may not look like much but they only happen when the freezing starts once I open that application. Another application which I noticed does the same is Heroic Linux Launcher but other than those two - nothing else.
Also once the issue starts of I try to go to a console tty out of the X server(ctrl + alt + f3 for example) the system hangs completely.
I even tried with Wayland just in case but still it’s the same.

I’m sure the issue is from NVIDIA’s driver because if I switch to the open source nouveau driver the issue doesn’t happen at all!
I’m currently using Arch Linux, but I also got the same issue before with Kubuntu and KDE Neon.
The driver is install from pacman, Arch’s Package Manager.

Seamus Riolo

nvidia-bug-report.log.gz (872.6 KB)

The gpu errors out with an XID 61, which is rather unspecific. One thing I noticed is that the gpu is at 75°C while doing nothing. Please check/clean your fans/heatsink. Might be first signs of the gpu dying due to constant overheating.
Nouveau can’t clock up the gpu so it always runs at base clocks is not heating up.

I will try to give a clean up thanks for pulling my attention on it didn’t notice, but I’m sure the tempreture is not the issue in this case since the problem starts with a system monitor specifically (and with a launcher). I mean, I run full-on compiz-fusion desktop effects on linux, and play heavy video games on Windows like Age of Century, Borderlands 3, Immortals Pheonix Rising and Vampyre to name a few and I don’t get any slow-downs/freezings which I would assume my PC would go insane if temps where and issue while gaming, a system monnitor is not something I expect to increase GPU temps especially compared to those.

I could only imagine the specific applications are triggering some “unexpected” performance level switch.
Did ths also occur with earlier drivers, e.g. 470?
Does this also occur when setting power-mizer to “prefer maximum performance” in nvidia-settings and then starting the application?

I tried with power-mizer max performance and again - system was good but as soon as I opened plasma-systemmonitor it went nuts, and the system was booted from the morning all stable till that time. Actually it looked like worst with that setting cause usually it takes time destabilizing this time it was instant. And as I said in the original post even closing the app doesn’t solve the issue.

Regarding driver 470 - I wasn’t using Linux during the time of that driver as I stopped using it for about 1.5years and just recently started again. I tried installing 470 yesterday as a test to see if older is better but it failed to compile on the current version of Arch Distro.

I need to put emphasize again that this issue only happens with plasma-systemmonitor which is a simple resource monitor and with Heroic Launcher(just the launcher no games launched) and that this system works flawless during heavy gaming and even compiling software etc etc. so the only two things that trigger the problem are very light simples apps and the heavy stuff runs without issues.

I attached another debug file during the crash that I had with the new power-mizer settings maybe it will be of help.

nvidia-bug-report.log.gz (423.0 KB)

There should be matching 470 legacy driver packages for Arch.
Please try setting kernel parameter ibt=off
Also, trying to downgrade to an lts kernel might be worth a shot.