NVidia Driver DisallowTCP connection

On linux, I configured the Xorg server (in gdm) to allow connection on TCP using the setting “DisallowTCP=false” (listening to port 6000)

When the system is running without nvidia module loaded, the port and connection is permitted:

netstat -na | grep 6000

tcp 0 0* LISTEN
tcp6 0 0 :::6000 :::* LISTEN

I loaded nvidia module and restarted the system, the nvidia module closes the port, then it’s not openable again!

netstat -na | grep 6000

{returns nothing - the port is no longer listening and services needing it no longer working}

So, is there some settings for the nvidia module related to this? Actually, even nvidia driver itself requires DisallowTCP=false (allowing tcp connection on port 6000) so Genlock can work!

The GDM setting DisallowTCP=false just starts Xorg with “-listen tcp”, the nvidia driver doesn’t have any influence on that. Did you check you’re still running an Xsession when the nvidia module is loaded or a Wayland session?
ps a |grep X

Thanks for pointing this out… Actually I was not running wayland, but by troubleshooting and trying multiple options between Xorg, and wayland, I found what causes the problem, when gdm detects nvidia gpu, it applies some rules to force using X, it seems that there was something wrong when these rules are applied!!

I disabled these rules, and I selected X11 manually (although this was my default), but now when gdm rules are disabled, the problem is resolved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.