Nvidia-driver installation errors

I’m new to fedora so lots of confusion here. I think I have the repositories set up properly. Perhaps someone can explain what might be done with the errors I’m seeing. I have nvidia working for
vmlinuz-5.7.0-0.rc0.git6.1.vanilla.knurd.1.fc31.x86_64 which I am currently using. If I try dnf reinstall nvidia-driver it responds with mo match for nvidia-driver. With dnf install nvidia-driver, I get
Last metadata expiration check: 1:21:45 ago on Wed 08 Jul 2020 03:21:26 PM PDT.
Error:
Problem: conflicting requests

  • package nvidia-driver-3:450.36.06-1.el8.x86_64 requires dnf-plugin-nvidia, but none of the providers can be installed
  • package nvidia-driver-3:450.51.05-1.el8.x86_64 requires dnf-plugin-nvidia, but none of the providers can be installed
  • package dnf-plugin-nvidia-1.1-1.el8.noarch is filtered out by modular filtering
  • nothing provides python(abi) = 3.6 needed by dnf-plugin-nvidia-1.1-1.el8.noarch
  • nothing provides python(abi) = 3.6 needed by dnf-plugin-nvidia-1.6-1.el8.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages)
    Is --skip-broken likely to result in more paint that I would want?
    Thanks.