Nvidia driver installation unmet dependencies

I have a laptop with a 1060 GPU which has Ubuntu 20.04 set up. I’ve had nvidia-driver-460 + cuda 11.2 installed and working until today. I tried to install ROS today and after adding sources and keys following this link, it didn’t allow me to install ROS saying some packages have unmet dependencies. After that I issued a apt autoremove and this removed the nvidia driver and cuda.

I still cannot install ROS and now trying to do apt install nvidia-driver-460 gives me unmet dependencies as well. Here’s the output of sudo ubuntu-drivers autoinstall which is similar to the apt install command output

Reading package lists... Done
Building dependenc    y tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-modules-nvidia-460-generic-hwe-20.04 : Depends: nvidia-kernel-common-460 (>= 460.39) but 460.32.03-0ubuntu1 is to be installed
 nvidia-driver-460 : Depends: libnvidia-gl-460 (= 460.32.03-0ubuntu1) but it is not going to be installed
                     Depends: libnvidia-ifr1-460 (= 460.32.03-0ubuntu1) but it is not going to be installed
                     Recommends: libnvidia-compute-460:i386 (= 460.32.03-0ubuntu1)
                     Recommends: libnvidia-decode-460:i386 (= 460.32.03-0ubuntu1)
                     Recommends: libnvidia-encode-460:i386 (= 460.32.03-0ubuntu1)
                     Recommends: libnvidia-ifr1-460:i386 (= 460.32.03-0ubuntu1)
                     Recommends: libnvidia-fbc1-460:i386 (= 460.32.03-0ubuntu1)
                     Recommends: libnvidia-gl-460:i386 (= 460.32.03-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

Here’s what I have tried so far and didn’t work

  1. apt purge *nvidia*, apt autoremove, apt autoclean and reinstall drivers
  2. sudo apt -f install and reinstall drivers
  3. sudo apt-add-repository -r ppa:graphics-drivers/ppa and reinstalling drivers

So far nothing changed the output I get from apt install nvidia-driver-460. Any help is really appreciated.

I have a 64bit Ubuntu installation on a core i7 machine. So why am I seeing i386 on the apt install output?

$ uname -a
Linux XXXX 5.8.0-44-generic #50~20.04.1-Ubuntu SMP Wed Feb 10 21:07:30 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.2 LTS
Release:	20.04
Codename:	focal

Those are the 32bit compatibility libs required for 32bit software like Steam. You first installed everything from the cuda repo, the driver included with it doesn’t provide those. Please check if you have have the cuda repo added in software&updates and disable it.

1 Like

You mean the 5th one in this list right? Great! It seems the driver is installing now. Thanks a lot.