NVIDIA driver is not loaded. Ubuntu 18.10

The hard reset on a surface should work like reboot, on logo press and hold power+volume until shutdown or something like that. Better check with someone who knows.

@generix I got it! Running smoothly again. Thanks!

@generix,

I have a similar problem, the Nvidia driver stopped working after one of the regular updates for ubuntu 20.04.
Please find attached
nvidia-bug-report.log.gz (115.7 KB)

Please help, I have been troubled with this for many days now…

You used the runfile installer to install the driver, this is not recommended and the driver broke on kernel update. Please uninstall the driver by running the runfile with --uninstall option, then install the driver from repo using the Software&Updates application.

@generix
Thank you so much, It worked. But instead of un-installing and again installing, I just ran the install from the run file again. (I will re-install from repo once I complete my priority work).
Once again thank you.

You can also use the runfile installer with --dkms switch to have the driver auto-compiled on kernel update.

Please note! There is a regression in the ubuntu-drivers-common that broke nvidia-prime and nvidia-settings. The problem is that the new ubuntu-drivers-common is using the file /var/lib/ubuntu-drivers-common/requires_offloading to decide whether an offloading is required but the file is no longer present in Intel mode.

You can fix it manually by editing a config file or there is already a fix in the nvidia-prime-applet package, just posted a couple of days ago. You find all details in the following thread: https://github.com/linuxmint/nvidia-prime-applet/issues/7

Hi, I read a lot of the issues before, but nothing really worked for me. Perhaps I have the issue like @ps-msi mentioned, but I cannot fix it this way.
Please find attached the report:
nvidia-bug-report.log.gz (367.7 KB)

[Possible SOLUTION ! for Black Screen UBUNTU and latest 460 driver!]
after 48 hours of struggle, managed to solve similar issue…

1 Like

Hi,

I’m having basically the same issues as everyone in this post, even after following all the suggestions. I’m currently running the 430 drivers for an MX230.

Things checked:

  • secure boot is disabled
  • no blacklist-nvidia.conf file exists
  • no multiple versions of drivers installed

my dkms status is as follows:

nvidia, 465.27, 5.0.0-31-generic, x86_64: installed
nvidia, 465.27, 5.4.0-74-generic, x86_64: installed

Cheers,
Eren

I am also having the same problem as everyone else, I started my own thread about it but have not received any feedback from nvidia.

Hi, I am also experiencing same problem. I can run nvcc --version and it displays relevant information. But when I run nvidia-smi, it doesn’t work. It works fine a few days ago.
nvidia-bug-report.log.gz (155.0 KB)

Please disable secure boot in bios or enable module signing in Ubuntu.

Dear all,

I’m using a MSI GP66 Leopard laptop, with Nvidia Geforce RTX graphic card. I installed Ubuntu 18.04 from scratch. But whenever I installed nvidia driver, after rebooting, the computer went to a black screen, and failed to open GUI. I have disabled secure boot in bios.

I’ve visited almost all links available on this and other Q&A forums, and tried their suggestions, but none of them practically solved my issue.

I installed nvidia-driver-465 using sudo apt-get install. I’ve also tried directly installing .run or .deb files as well.

The attached is my nvidia bug report; one with ‘nvidia-drm.modeset=1’ in ‘/etc/default/grub/’ for ‘GRUB_CMDLINE_LINUX_DEFAULT’, while the other without this param setting.

Once entering tty3, the command ‘nvidia-smi’ did work without any error though. If I change back to intel using ‘prime-select’, the system starts its GUI successfully but leading to ‘nvidia-smi’ failure.

I also tried changing from gdm3 to lightdm but the problem still remained the same.

Any help would be much appreciated.

nvidia-bug-report.log.gz (316.8 KB)
nvidia-bug-report-with-modeset.log.gz (337.1 KB)

You need to install a newer kernel that supports your intel gpu.
https://www.techrepublic.com/article/a-case-for-and-against-upgrading-ubuntu-to-kernel-5-8-and-how-to-do-it/
Though this might break the nvidia driver since a newer gcc is needed, so YMMV.

thank you generix for your answer.
I want to use my nvidia gpu though, not the intel one. could you provide any suggestion for that?

The intel gpu is primary, driving the display. Without it, nothing will work.

Hello,

I am also facing this same problem with nvidia-smi:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I am using:

  • MSI GS66 with i7-10870H, with VGA GeForce RTX3070.
  • Ubuntu 20.04 with 5.12.10-051210-generic kernel
  • safe boot disabled.

Statuses:

  • dkms status gives: “nvidia, 470.42.01: added”
  • nvidia-settings gives:
    "ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:20633): GLib-GObject-CRITICAL **: 15:15:19.715: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 15:15:19.717: PRIME: No offloading required. Abort
** Message: 15:15:19.717: PRIME: is it supported? no
"

  • no blacklist_nvidia.conf files exist in /lib/modprobe.d

I’m also having trouble connecting the laptop to an external monitor.

Please help! Thank you.

nvidia-bug-report.log.gz (129.6 KB)

Seems the kernel driver doesn’t compile, please try reinstalling the generic headers for your kernel, also try running
sudo dkms install nvidia/470.42.01
and post any errors and make.log

(post deleted by author)