Nvidia drivers cause transparency and artifacting when running Netflix in linux via Wine

Using the recently discovered method of running Netflix in linux under Wine, I tried to use this method via Erich Hoover’s PPA. (It can be found here on I Heart Ubuntu: http://www.iheartubuntu.com/2012/11/ppa-for-netflix-desktop-app.html). I installed his modified version of Wine, and got it all setup as described in the article. When I tried to run Netflix, I found that the sound worked, but the video went transparent, with rectangular blocks of fragments of images from my other two monitors. I tried this process several times and got a consisent result.

I then tried using the PPA setup in Elementary OS, which like my usual OS Linux Mint 13 is based on Ubuntu 12.04. The key difference here is that I do not have the propietary Nvidia drivers installed in Elementary due to a bug in LightDM that causes a crash to command line. I found that in Elementary the PPA works flawlessy, and Netflix works. Based on what I found, and based on comments I have read on various websites, my best guess is that the culprit is the Nvidia drivers. I didn’t run the bug command because I was not sure how useful the information would be due to the unique setup of the issue. I’m hoping someone can provide me some direction on how to work this issue.

My System
2 Nvidia 680 GTX ruinning in SLI
ASUS Xonar Soundcard
ASUS TUF series X79 Sabertooth Motherboard
Intel Xtreme 3960x Processor
16 GB Corsair Dominator GT 2133MHz RAM
3 Monitors all running in 1980 by 1080
Linux Mint 13 64 bit OS
Elementary 64 bit OS
Nvidia 310 series beta driver in Linux Mint 13