NVIDIA Drivers not working with new kernel

Hello!

I had a previous issue with my laptop (i7-12700H w/RTX3060) not picking up the drivers which was resolved by installing the liquorix kernel (which as far as I understood was 5.17.0-5 (a patch for 5.17.0)).

While this kernel did fix the driver problem it introduced some issues that I had to live with for quite some time, particularly the CPU speed apparently being capped at 2700MHz (that was the max listed speed when I did lscpu | grep MHz), even though it should be 4700MHz as listed in Intel’s website. I also had other minor things such as keyboard backlight brightness keys not working.

Long story short today I updated my kernel to 5.17.7 via mainline. The keyboard backlight brightness keys now work and when I lscpu | grep MHz the max MHz is correct. However, when I do nvidia-smi the system no longer picks up the GPU driver. I tried booting up the liquorix kernel and it also doesn’t recognizes it (although gradients look normal, which they didn’t before I fixed it the first time).

What should I try?

The mainline kernel header package is incompatible, only works/installs with 22.04 so the driver can’t be built. Please revert to the liquorix kernel and update that, current version should be 5.17.0-11

Okay so I first removed the already-installed kernel and the ppa repo (also did autoremove to get the cleanest install I could). Then I did the installation steps again, added the repo, apt updated and installed.

nvidia-smi works fine now, so do the keyboard backlight keys. However, the lscpu | grep MHz command still shows a max mhz cap of 2600MHz instead of 4700.

I managed to fix the cpu max mhz thing by modifying the grub file.

sudo gedit /etc/default/grub

edit the “GRUB_CMDLINE_LINUX_DEFAULT” adding “intel_pstate=enable”

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=enable"

and finally

sudo update-grub

Reboot, checked again and it’s back to 4700MHz Max Speed. Now everything works as it should. Thanks again!