NVIDIA Drivers using MESA OpenGL implementation on ubuntu 18.04LTS

Hi All,

I hope you are doing safe and sound!

I’m using Ubuntu 18.04LTS and followed the instructions here https://docs.microsoft.com/en-us/azure/virtual-machines/linux/n-series-driver-setup?toc=/azure/virtual-machines/linux/toc.json#install-grid-drivers-on-nv-or-nvv3-series-vms to install nvidia grid drivers.

I see that the drivers are installed and here is the nvidia-smi output:

nvidia-smi
Tue Jun 23 01:36:44 2020
±----------------------------------------------------------------------------+
| NVIDIA-SMI 440.56 Driver Version: 440.56 CUDA Version: 10.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 Tesla M60 On | 00000001:00:00.0 Off | Off |
| N/A 34C P8 14W / 150W | 0MiB / 8129MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

Now I am trying run the benchmark (glxgears and unigine) to test the gpu performance but i noticed that they are using CPU instead GPU.

Looking at the glxinfo output, i observed that it’s using MESA OpenGL runtime instead NVIDIA OpenGL runtime.

OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

Here is my lspci output:
0000:00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 03)
0000:00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
0000:00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:08.0 VGA compatible controller: Microsoft Corporation Hyper-V virtual VGA
0001:00:00.0 VGA compatible controller: NVIDIA Corporation GM204GL [Tesla M60] (rev a1)

My Kernel Version:

uname -r
5.3.0-1028-azure

I have tried re-installing and updating but didn’t worked. Also tried with ubuntu 16.04 but none of them worked.

How can i change the NVIDIA config to use NVIDIA OpenGL runtime instead of MESA? Thanks!