Nvidia-drm driver is not loading on boot but loading manually

Hello! I’m using Arch Linux with the latest software on my ASUS UX550G.

GPU hardware on board is:

  • Intel Corporation UHD Graphics 630 (Mobile)
  • GeForce GTX 1050 Ti Mobile

Software versions are:
Linux 5.5.13-arch2-1
xorg-server 1.20.8-1
nvidia 440.64-9

I want to use Prime offloading but for some reason the nvidia driver doesn’t initialize on initial boot (nvidia_drm driver is not listed in lsmod) and it’s not available to X server.
I’ve tried adding nvidia_drm to /etc/modules-load.d directory, but that doesn’t help.
However if at the time when the OS has started I load nvidia_drm manually (with modprobe) and restart X server then my NVIDIA card is detected by X server and I’m able to use Prime offloading.

Could you please help with debugging of this issue? Why nvidia_drm driver is not loaded on boot?

Okay, as soon as I wrote this post I realized that I have bumblebee package installed which blacklisted nvidia-drm. When I deleted bumblebee everything just worked!

1 Like

@alexandervarnin If your issue has been resolved, then please mark it as such.

1 Like