Nvidia fan issue (Linux)


I have a Asus R510-dm205d with nvidia gforce 950M. My OS is Artengo Linux. The problem is that when I enable bumblebeed.service and restart the SO, the gpu fan start to working at max speed. What can I do?. This is what I have done:

sudo pacman -Rc xf86-video-nouveau

sudo pacman -S bumblebee mesa xf86-video-intel nvidia lib32-nvidia-utils lib32-virtualgl lib32-mesa-libgl nvidia-settings bbswitch

sudo gpasswd -a $USER bumblebee
sudo gpasswd -a $USER video

sudo systemctl enable bumblebeed.service

sudo shutdown -r now


It’s a laptop, probably has nothing to do with NVIDIA fan controls and everything to do with your motherboard EC (embedded controller). I would ask on Asus forums, but wouldn’t get your hopes up.

You can probably underclock your card which will naturally lower temperature and thus fan speed though.
You could also decrease power limit via nvidia-smi tool so that you keep temps in check.

Thank you tpruzina. I solve it adding acpi_osi=! acpi_osi=“Windows 2009” to the kernel parameters.