NVIDIA Gaming PC - Ubuntu 18.04 AWS AMI GPU Usage Problem;

Hello,

I am using NVIDIA Gaming PC - Ubuntu 18.04 AMI on AWS. (g4dn.xlarge instance) I installed XRDP on this server and connect with RDP and use Ubuntu Desktop. The GPU does not work even though there is an nvidia driver on the server and a 3D controller between the display hardware.
Mesa Project and SGI still appear when I run glxinfo.

I do the GPU test by running the glxgears command and it still seems to be using the CPU. It says “No running processes found” in the output of the nvidia-smi command. NVIDIA driver is also running on the server because I get the answer to nvidia-smi query.

Components installed on the server and server details:

Server operating system:
Ubuntu Server 18.04.4 LTS Bionic

NVIDIA card details:

  1. Card Model: NVIDIA Tesla T4
  2. NVIDIA Driver Version: 430.50
  3. CUDA Version: 10.1

Components installed on the server:

  1. XRDP was installed to access RDP. > https://en.wikipedia.org/wiki/Xrdp

  2. For Ubuntu desktop interface, gnome is installed and other associated services are installed.

  3. The nouveau was disabled to ensure that the VGA was not active.

  4. glxgears (apt-get install mesa-utils)

Could you help with this?

Thanks.

Thank you for your feedback.

We are aware of this issue and already have a fix for it. It will be available with an upcoming AMI update. We expect the update to be available in the next week or so.

Hello,

Is there any progress?

Thanks.

Same problem.

Starting from this AMI (NVIDIA Gaming PC - Ubuntu 18.04 AWS AMI) if I apt install either gdm3 and gnome-session, or if I install the full ubuntu-desktop package, the nvidia driver no longer loads at boot. Rebooting the instance by hand shows the nvidia driver modules are no longer installed. Manually installing the driver again works, but of course that defeats the point of using a preconfigured image.

Even worse, if I use Hashicorp packer to provision a new AMI based on this one, where the provisioning steps include using apt to install the ubuntu-desktop package, the resulting AMI boots partway but utimately fails its status check and the instance at that point cannot be accessed via ssh or via the AWS session manager. At that point all you can do is terminate the instance.

Dear,

Is there somebody that has written a line by line tuturial to get a powerful gpu ubuntu pc ready for gaming?
In fact I would like to do like https://shadow.tech/ but with a ubuntu guest os running steam games or lutris games.

Eric

I’ve tried starting with the latest NVIDIA Gaming Ubuntu 18.04 that was released a couple days ago on AWS West-2 on a G4. I installed KDE and NoMachine for desktop. I then installed Lutris and vulkan libraries, but starting Lutris, it states that Vulkan is not available on the instance.

I also tried building the image from scratch from a Ubuntu 20.04 minimal ami and installing the NVIDIA T4 driver following the AWS instructions and then KDE, Lutris, and vulkan drivers, but same issue of Lutris saying vulkan was not supported. This caused the NoMachine display to not scale over 1280x720 as well.

I tried installing the normal NVIDIA drivers, with the same setup as above, and also, vulkan not available.

I would really like to use these AWS G4 instances with Linux, I’m not willing to pay the microsoft tax doubling the cost of the instance…

Any update on this, it’s been a couple of months now.