NVIDIA GRID K2-Windows Server 2012 R2-"Manage 3D Settings" not working

hi, if anyone can help on my issue.

We have recently installed Dell PowerEdge R730 server, with 4 X NVIDIA GRID K2 graphics card. I installed the latest NVIDIA driver from their website for GRID K2 card, version 369.26. The server has all Windows Updates installed and configured.

Now, I can open NVIDIA control panel utility, however when clicking "Manage 3D Settings" from it, it does not anything, seems "Manage 3D Settings" is not working or coming-up. Now for our application, we need to go into 3D settings and configure something.

The server has on-board Matrox G200eR display card, and I tried disabling it from Windows device-manager as well as from BIOS. It didn’t work.

Any idea why Manage 3D Settings is not working and how to resolve it?

Hi

The R730 can support a maximum of 2x K2 cards (or equivalent) per chassis.

Manage 3D Settings isn’t available on Server Operating Systems in the normal way, because when you make changes to it, it effects everyone on the server. It is assumed that if you’re using a Server Operating System, you will be supporting multiple sessions. To use those 3D Settings within a session, you need a Desktop Operating System where there can only be 1 session connected, or you can connect via VNC Client and configure for all sessions at the same time.

Also, are you using a Hypervisor?..

Regards

Ben

Hi,
you should be able to Manage 3D settings but only from the console session on the RDS VM. The changes made here are valid for all user sessions. As Ben already mentioned there is no way to customize 3D settings individually for a TS user session as the NVIDIA control panel isn’t even available.

Regards

Simon

I am sorry for my delayed reply.

Yes, we were trying from iDRAC console session (like HP ILO) and even local console session by connecting local keyboard and mouse. It didn’t work. I understand about TS session it wont work.

When I click on "Manage 3D Settings", it does not do anything, nothing happens. The driver and software were loaded successfully, Windows Server 2012 R2 was installed from scratch. Its a fresh OS and drivers.

Any help will be appreciated. We need to access the menu for our application.

Thanks.

In my case it works perfectly with XenCenter Console:
http://imageshack.com/a/img922/2514/YTuj3P.jpg

strange! in my case the driver and software are installed successfully. i just did a full clean re-installation, still the same issue. nothing happens when i click “Manage 3D Settings”. I connected to the server by console. there must be a reason to that. NVIDIA support advised to do a clean installation, that’s what we just did. Not sure how to resolve this.

Can you clarify your setup please.

By the sounds of it, you’re not using a Hypervisor? … How many K2 cards do you have installed in the R730?

If you’re bare metal, maybe because the OS can see multiple GPUs (2 GPUs per K2), the driver is unable to configure all the GPUs at the same time, which is what would be required.

Regards

Ben

its not Hypervisor. Its a stand-alone dedicated hardware, not a virtual machine. I am connecting by Dell iDRAC console (like HP ILO), also tried connecting by local console with local keyboard and mouse. We created a case to NVIDIA support, they advised to clean re-install driver software, we did that, still the same issue.

We have two servers, both same configurations and spec. This issue is on both servers.

For bare metal support see: https://griddownloads.nvidia.com/flex/GRID_4_Product_Support_Matrix.pdf

Hi.

I will testing the performance comparison between K2 and M60.
However, during testing, the same error as "3D Manager Settings" was not enabled as above.

I installed GRID software on windows server 2012 r2. I could see it on an M60 GPU card, but I could not see it on a K2 GPU card.

If you have resolved the above errors, or if you know the solution, please answer.

Well, NVCPL for RDSH was introduced in a later driver version so there is no support for R367 branch (K1/K2).

"sschaber" Thank you for answer.

One more thing I would like to ask.

Symptom :

  1. I installed Windows 2012 r2 as a bare metal platform.
  2. After that, I installed "363.36_grid_win8_win7_server2012R2_server2008R2_64bit_international"
    driver in windows.
  3. I tried to check "3d Manager Setting" in NVCPL with the console, but I could not found it.

Is this the right symptom?

How did you connect to the console? With IPMI/ ILO? Otherwise you won’t get the console…

Hi all,

I have the exact same problem. I have a dell r730 with one grid k2 card. After fresh installing server 2016 and the newest nvidia driver, my nvidia control panel looks like my attached screenshot. “Manage 3d settings” link doesn’t do anything, and the option is missing from the left. Did anyone manage to solve this?

https://i.imgur.com/gaJGuln.png