NVIDIA GTX 660/650 Ti and Ubuntu 18.04: Nvidia driver isn't loading

Hi there.

Ubuntu loads and X runs fine. But the graphics card driver isn’t being used (nouveau is being used instead).

I installed the 430 driver with apt.

$ apt list --installed | grep nvidia

libnvidia-cfg1-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
libnvidia-common-430/bionic,bionic,now 430.50-0ubuntu0.18.04.1 all [installed,automatic]
libnvidia-compute-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
libnvidia-decode-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
libnvidia-encode-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
libnvidia-fbc1-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
libnvidia-gl-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
libnvidia-ifr1-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
nvidia-compute-utils-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
nvidia-dkms-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
nvidia-driver-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed]
nvidia-kernel-common-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
nvidia-kernel-source-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
nvidia-prime/bionic-updates,bionic-updates,now all [installed]
nvidia-settings/bionic,now 418.56-0ubuntu0~gpu18.04.1 amd64 [installed,automatic]
nvidia-utils-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]
xserver-xorg-video-nvidia-430/bionic,now 430.50-0ubuntu0.18.04.1 amd64 [installed,automatic]

I’ve been going around and around in circles. I’ve tried all the recommendations from all the similar topics. Please have a look and see what you can see from the log report.

Does nvidia black list exist?

$ cat /lib/modprobe.d/blacklist-nvidia.conf
cat: /lib/modprobe.d/blacklist-nvidia.conf: No such file or directory


Black list nouveau

$ cat /etc/modprobe.d/blacklist-nvidia-nouveau.conf
blacklist nouveau
options nouveau modeset=0
$ cat /lib/modprobe.d/blacklist-nvidia-nouveau.conf
blacklist nouveau; options nouveau modeset=0


Other modprobes

$ $ grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/lib/modprobe.d/nvidia-kms.conf:options nvidia-drm modeset=1

Look for UEFI secureboot

$ zcat nvidia-bug-report.log.gz | grep -i secureboot

Run xrandr from Desktop

$ xrandr --verbose > journal-nvidia.log

Set nvidia profile

$ sudo prime-select nvidia
Info: the nvidia profile is already set


Card and drivers

$ lspci -nnk | grep -iA3 vga
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106 [GeForce GTX 650 Ti] [10de:11c6] (rev a1)
  Subsystem: Gigabyte Technology Co., Ltd GK106 [GeForce GTX 650 Ti] [1458:3618]
  Kernel driver in use: nouveau
  Kernel modules: nvidiafb, nouveau

Other things

$ uname -r
$ gcc --version
gcc (Ubuntu 7.4.0-1ubuntu1~18.04.1) 7.4.0

Thanks again. Regards.
journal-xrandr.txt (7.2 KB)
nvidia-bug-report.log.gz (97.4 KB)

You’re booting an old kernel with an old initrd. Hold down shift on boot to get to the grub menu and select the correct kernel (4.15.0-66)

Hi there. Thank you for spotting that. Seems that apt and grub were installing into a directory that boot wasn’t using. I’ve fixed that.

Settings now shows graphics as llvmpipe rather than GTX that I was expecting. I’ll go ahead and clean out nvidia and reinstall.

Please mark this solved! Thanks again.