NVIDIA installer 319.49 fails to build kernel module on Linux kernel 3.11.1-200.fc19.i686

Hi,

I have always used the RPMFusion repository to keep my graphics card’s drivers up to date and until about a week ago, it has worked great (I even beat Portal on Linux).

The problem all started when I received an update for the Linux kernel (3.11.1-200.fc19.i686) through my package manager. I installed it and tried to boot it and it hanged on ‘Reached target Graphical Interface’. I was able to access tty2 - 6 as normal, though.

I’m able to boot the older kernel (3.10.11-200.fc19.i686) and it runs the X server just fine but it’s somewhat unstable; running DefleMask sometimes crashes the whole system and the new kernel only allows access to the bash command line.

When I tried to install the NVIDIA Driver 319.49 using the official .run file from the NVIDIA website in the bash command line on the newer kernel, it failed to build the kernel module.

Is there anything I can do to have the NVIDIA drivers working on the new kernel? I would like to avoid nouveau as much as possible because it breaks Flash player’s fullscreen and Portal.

Many thanks in advance,
UltrasonicMadness

My setup:
Operating system: Fedora 19 KDE Spin

Graphics card (lspci output):
01:00.0 VGA compatible controller: NVIDIA Corporation G86 [GeForce 8500 GT] (rev a1)
nvidia-installer.log (115 KB)

Check if this link helpful to you : https://devtalk.nvidia.com/default/topic/610580/linux/325-15-drivers-do-not-compile-witth-3-11-1-kernel/post/3949798/#3949798

Sorry to sound like an idiot here but do I add the code to the end of mm.h or edit a specific part of it?

http://download1.rpmfusion.org/nonfree/fedora/updates/19/i386/repoview/kmod-nvidia-3.11.1-200.fc19.i686.html

It’s fixed now; an update for akmod-nvidia was just released on rpmfusion today.