Nvidia isaac docker

hi,
We tried to install docker image ubuntu 18.04 in ubuntu 20.04 for isaac sdk workstation but it fails with an error showing
Err:1 Index of /compute/cuda/repos/ubuntu1804/x86_64 InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY A4B469963BF863CC

kindly support us to install docker image 18.04
here below I added the command we used :
~/isaac$./ ./engine/engine/build/docker/install_docker.sh
~/isaac$ ./engine/engine/build/docker/create_image.sh

Solved the Issue by following https://github.com/NVIDIA-ISAAC-ROS/isaac_ros_common/issues/21

Inserting the following in saac/engine/engine/build/docker/Dockerfile solved my issue

 # Fundamentals
RUN apt-key adv --fetch-keys https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/3bf863cc.pub

This is the dockerfile after editing
Dockerfile (3.1 KB)

Looks like you’ve already solved this issue. For future reference, here’s a link to the NVIDIA blog post about this repository key invalidation issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.