NVIDIA Jetson Nano 2GB Developer Kit available now

SDK manager won’t work on Jetson Nano 2GB due to the requirement of 8GB memory, right?

Hi @janmouli, the SDK Manager itself is installed onto an x86 Linux PC that’s running Ubuntu (the PC is required to have 8GB memory, not the Jetson). The PC running SDK Manager will then flash the Jetson device over micro-USB cable.

However since Jetson Nano can use SD card, it’s recommended just to use the SD card image as shown here:

The SD card image already comes with the JetPack components pre-installed (CUDA, cuDNN, TensorRT, ect), so you don’t typically need to use SDK Manager to setup Jetson Nano. Just flash the SD card image to your SD card using Etcher from your PC, then put the SD card into your Nano.

Hi @Dusty, that is good to know. I spent days in trying to make jupyter working with opencv 4.5.0 on my Jetson Nano 2GB without luck. SDK Manager was tried but … Is there a way to make the combination (jupyter with opencv 4.5.0) work on the Jetson Nano 2GB? Thank you.

If you wish, you can use the l4t-ml container which already has JupyterLab installed. Here is how I install JupyterLab into container in the Dockerfile.

For latest OpenCV, you would need to build it from source - you can see @mdegans OpenCV build script here:

Hi @Dusty, I had trid JetPack 4.4.1 (L4T R32.4.4), JupterLab server worked but not opencv (4.1.1, the default one came along with the SD card image). Is there a way to make the default opencv 4.1.1 work with JetPack 4.4.1 (L4T R32.4.4)? I hope that is just me missing something.
I’ll give the mdegans’ repo a try for the latest opencv (4.5.1) even many others did not work on the Jetson Nano 2GB at this moment. Thank you.

If you are referring to the l4t-ml container, I don’t believe OpenCV 4.1.1 is installed into that container. You can add JetPack’s OpenCV 4.1.1 into a container like was done here: https://github.com/NVIDIA-AI-IOT/jetbot/blob/cbf6f1b5a3285ad3bbb18ec552ed79846d1e2529/docker/base/Dockerfile#L47

Or if you want to use the dlinano container, that already has JupyterLab + OpenCV 4.1.1 (see Getting Started with AI on Jetson Nano course)

You could also install JupyterLab directly onto your device (outside of container) like in this post: How to Install Jupyter Lab on JP4.4

It sounds like “dlinano container” could be a solution. Just wondering why the setup (jupyter+opencv+cuda) is so complicated with JetPack on Jetson Nano 2GB. I can’t believe that there is no straightforward ways to get the setup done. Anyway, thank you.

Nvidia released Linux kernel 4.9.140 patches for its ARM linux devices 2 years ago, and there was no new kernel updates since then.
You can’t install a newer Linux kernel with support of Wi-Fi 6. And you need to know that Nvidia stops releasing updates for their old devices even if they still runs on the same CPU.
And if you ask Nvidia on their forum, about when new kernel support going to be released, they will tell you “Customer can try to do that by their own”.


Jetson Nano runs on the 5 years old hardware, since it is using the same GPU and CPU as used in the first revision of Nintendo Switch, but JN has 2 times less GPU core count.
When buying this you should be ready that you may stuck on the kernel 4.9.140 forever with no kernel security patches.
If you agree with Ubuntu to install all updates to v20 it will break all the GPU drivers.
So the only way to make things work is to not buy that device or sell it if you have already.
Either you will need to wait 5 more years until community release some good software support of it.

@julyighor, The insight is appreciated. Thanks.

@janmouli

I’ve tried building my OpenCV script on a 2GB nano. My tips for that would be:

  • use a swap file/device
  • start it at night and i’ll be done in the morning

If you have any issues, please report them on GitHub with any logs and i’ll try to get around to looking into the issue. I do have a 2GB Nano to test with. I’ve been busy recently with work, but I try to prioritize popular repos like the OpenCV build script.

1 Like

If you install JupyterLab natively onto your device (outside of container), then it should have access to the OpenCV that comes with JetPack. If you are running it inside of a container, then you need to install OpenCV into the container as well.

Hi @julyighor, we plan to upgrade Jetson devices to newer 5.x kernel and 20.04 LTS next year.

1 Like

That is great news! But if you are going to release single kernel version patches per 3 years, it makes no sense.
And if you chosen LTS kernel version but released no updates, it is also makes no sense to chose LTS.
LTS made for you to make you able release kernel patches updates as often as the official kernel.org releases with minimal efforts, not just once.

1 Like

The kernel version upgrade to 4.9 was released in 2019. There are a large number of patches required to the upstream kernel to support Tegra. We also backport patches from upstream. Even though the kernel version is 4.9, there are updates to it every JetPack release. However we do have plans for the future to help mitigate this and shorten the release cycle.

1 Like

That is not something that customers can do by their own, right @kayccc?

Nice, please tell where can I find the list of patches ported from a newer kernels to the 4.9.140?

If you needed full GPU / accelerator support, due to the volume not typically - although there are some software ecosystem partners with the expertise. As mentioned, this is something we are trying to make significantly easier in the future.

I’m not aware of a specific list of just those patches, but the commit logs can be found at http://nv-tegra.nvidia.com/gitweb/?p=linux-4.9.git From what I can tell they are mostly high-priority security/stability patches. There are also many patches each release from NVIDIA. We understand however that some developers wish to move to newer kernel, so we plan to do that and also make future upgrades easier to do.

3 Likes

Can you explain what the difference is? Is it possible to support both versions with the same image at all?

After weeks trying, I still can’t make GPU/CUDA working along with (at least close to) latest OpenCV (4.4+) and TensorFlow (2+) via Jupyter Lab remotely on my Jetson Nano 2GB with JetPack 4.4.1 (L4T R32.4.4). It seems to me that I was working on a semi-open platform. Please let me know if there is actually a way by which can accomplish the setup.
Meanwhile, I hope this request could be addressed within the plan upgrading Jetson devices to newer 5.x kernel and 20.04 LTS next year. I would be too ignorant to waste more weeks on trying another similar semi-open platform again. Thank you.

Someone please help !

Sorry Sir!  I am newbie.

After I  bought Jetson nano 2GB, I joined two free course.  One is "Getting Started with DeepStream for Video Analytics on Jetson Nano"!

However, I try the course SD image dsnano_v1-0-0_20GB_200131A on Jetson nano 2GB.  It does not work!  Can you help me?  Or create appropriate SD image for Jetson nano 2GB?