Nvidia Jetson Nano failing to boot with Xubuntu Image

Jetson Nano Boot failure


I am trying to use this custom Xubuntu Image I found here to run ros2 Foxy Fitzroy on Ubuntu 20.04 on a Nvidia Jetson Nano. When I flash my SD card with the image, and put it into the jetson, I get the initial boot logs, but then it asks for my user password, waits about 5 seconds, and fails to load the image. I cannot copy the log images, but I attatched a video to show what is going on. The last line that is logged before it shuts down the Jetson is “save context image failed”. After it shuts down, it waits a few more seconds before trying to boot again, and the process repeats itself. While troubleshooting last night online, it ended up working on its own, and I was able to access the desktop (and download ros2 and some other packages). Then I rebooted the system, and its back to this booting issue. I cannot find anything online to help explain what is wrong, and am really looking for some guidance/information on what I can do. I’ve reformatted my SD card, tried other SD cards with the same image (to check if the SD card was the issue), tried SD Cards with a different image (to see if the Jetson was the issue) and tried another Jetson (the problem persist). I am not sure if I will receive the assistance I need, given that the image is not the Jetpack image from Nvidia, but I figured I would ask.

Hi kyleldscott,

I can’t help on this issue as it’s not provided by NVIDIA, you may need to contact with the image provider to know how to resolve the problem.