Nvidia Jetson Power Consumption and Shutdown

We are using Nvidia Jetson Xavier Development kit for building some AI application. We are running multiple inference models in parallel to achieve our requirement.

To achieve required throughput, we have kept the Jetson Power Mode to “MAXN” (you can see in snapshot on top right corner) and we are powering the board via a 60W adapter (12V, 5A).

We are seeing that, after running the inference model for a minute or so, the Dev kits shuts down. We recorded the video of Power Consumption and Temperature. Here is the snapshot, which was taken a second before shut down.

Why do you think the shutdown is happening?

  • Temperature doesn’t seem to be a problem, as all temperatures are below SW Shutdown limit. Do you see any problem?
  • Total power consumption of Dev kit is around 40.724W (Summed up Power Reading Column). We know that, it is beyond 30W designed capacity. Do you think, this is the problem?

In some of the Nvidia forums it is listed that, shutdown may be due to voltage drop across a resistor inside the Dev it. We will investigate it if above stated problems are not causing any shutdown.

Hi, the temperature and current look fine. Have you tried another power supply, like DC supply? It could be supply capability issue. And yes it will be helpful to check the voltage level of the input end on board.

Thanks @Trumany. One question, can we power the board using Type-C power supply? to its USB Type C PD port.

Sure, that’s OK.

@Trumany Thanks!!

Just to let you know,

I’ve tried various power supplies, including usb-c, and simply changing the power supply does not fix the issue, this is a occurring due to an unknown issue.

You should expect this problem to occur randomly into the future, in some cases it does not properly reboot after shutting down, instead it will go into emergency mode and you will need to perform a manual power cycle for a successful reboot.

I’m still trying to figure out a way to fix it that doesn’t require adding in extra hardware, but i have yet to uncover anything, and in critical places i have to use a raspberry pi to toggle the jetson’s power supply On and Off.

Hi @rsc44 Thank you for your reply. Sorry I am seeing it after a month!!

If you uncover something, please let me know and I think if it is some serious issue, we should ask for an errata in Nvidia datasheet.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.