NVidia Jetson Xavier GUI glitch

Hello.

I’m working on getting Autoware working on Jetson Xavier, but I’ve faced a GUI glitch when the window doesn’t clean when UI elements redraw. This leads to a window where UI elements, including text, just overlay on top of previous drawing. Also, noticed the same in “emacs” where the scroll bar on the right do the same.

(Screenshots attached, where GUI breaks after I activate RViz).

Has anyone faced the same problem or could help me?

https://imgur.com/a/TURK8l6

yahrus,

Thanks for sharing this screenshot. Does this issue ever happen before RViz initialize?

Could you share the way to reproduce issue?

With Autoware it happens after pressing any button, not sure if you are able to reproduce it intentionally.

It might be something with Window Manager or drivers or smth else. For example, at the screenshots, I’ve opened the “emacs” and when I tried to scroll the scrollbar, it glitched the same way (doesn’t clean its previous position when moving).

It sounds emacs itself is able to reproduce the issue, isn’t it?
Could you share your steps of installing emacs?

Yes, emacs also has this.
After I’ve installed Jetpack (v4.0 if I’m correct), emacs was already installed.

https://imgur.com/3vC4s9I.jpg

We are trying to reproduce this issue on devkit. Your error is also on devkit, isn’t it?

Yes, it’s on Jetson AGX Xavier.

nvidia@jetson-*************:~$ head -1 /etc/nv_tegra_release 
# R31 (release), REVISION: 0.2, GCID: ********, BOARD: t186ref, EABI: aarch64, DATE: Sat Sep 29 05:14:38 UTC 2018

nvidia@jetson-*************:~$ uname --kernel-release
4.9.108-tegra

yahrus,

Could you also verify it on x86 device too? We would like to confirm if it only happens to tegra.

Any update?

I assume that this might be an exceptional case, as I haven’t faced this problem on any other device and also was not able to find similar issues online. Not sure if anyone else had this.

I thought that if somebody had this issue, so he could respond here on how he has solved it. Maybe, I should try to update the Jetpack to the last version and I will comment later if I succeed.

Thanks. Please update if you find anything.

Any feedback?

Updated to the latest Jetpack, still same problem.

Console gives the following output:

(runtime_manager_dialog.py:32369): Gtk-WARNING **: 12:34:37.289: for_size smaller than min-size (0 < 3) while measuring gadget (node trough, owner GtkScale)

(runtime_manager_dialog.py:32369): Gtk-CRITICAL **: 12:34:37.289: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScale

(runtime_manager_dialog.py:32369): Gtk-WARNING **: 12:34:37.289: Negative content height -2 (allocation 0, extents 1x1) while allocating gadget (node trough, owner GtkScale)

Please follow up my previous question: is this also reproduced on desktop platform?

If this is an issue that can also reproduced on ubuntu 18.04 on other platform, it is not an issue we could resolve.

Yes, it can be reproduced on a desktop. Apparently, the problem might be with gtk+ on ubuntu 18.04 as I have the same issues on another Xavier unit and also on a laptop.