Nvidia-l4t-jetson-orin-nano-qspi-updater install error

I purchased a jetson orin nano developer kit and I’m following the official tutorial to update my firmware in order to install jetpack 6.0. I think I have updated my firmware to 5.0, though when running

sudo nvbootctrl dump-slots-info

I get Current version: 35.3.0 instead of 35.5.0 as written in the tutorial. When I run

sudo apt-get install nvidia-l4t-jetson-orin-nano-qspi-updater

I get the following ERROR. BSP version 2294528 is not supported. error:

Preparing to unpack .../nvidia-l4t-jetson-orin-nano-qspi-updater_36.3.0-20240424200557_arm64.deb ...
3767--0005--1--jetson-orin-nano-devkit-
Info. Installing mtdblock.
Info. Active boot storage: mmcblk1
Info. Legacy mode: false
TNSPEC 3767-300-0005-M.1-1-0-jetson-orin-nano-devkit-
COMPATIBLE_SPEC 3767--0005--1--jetson-orin-nano-devkit-
TEGRA_LEGACY_UPDATE false
TEGRA_BOOT_STORAGE mmcblk1
TEGRA_EMMC_ONLY false
TEGRA_CHIPID 0x23
TEGRA_OTA_BOOT_DEVICE /dev/mtdblock0
TEGRA_OTA_GPT_DEVICE /dev/mtdblock0
Info: Write TegraPlatformCompatSpec with 3767--0005--1--jetson-orin-nano-devkit-.
ERROR. BSP version 2294528 is not supported.
dpkg: error processing archive /var/cache/apt/archives/nvidia-l4t-jetson-orin-nano-qspi-updater_36.3.0-20240424200557_arm64.deb (--unpack):
 new nvidia-l4t-jetson-orin-nano-qspi-updater package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/nvidia-l4t-jetson-orin-nano-qspi-updater_36.3.0-20240424200557_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

What is wrong? How to solve this problem? Thank you in advance.

That means clearly it’s still 35.3.
You need to first update to 35.5 following this:
https://docs.nvidia.com/jetson/archives/r36.3/DeveloperGuide/SD/FlashingSupport.html#updating-jetson-orin-nano-devkit-from-jetpack-5-to-jetpack-6

1 Like

I’m using a JetPack 5.1.3 SD card. I’ve rebooted 10+ times, sudo systemctl status nv-l4t-bootloader-config shows 0/SUCCESS, but nothing changed and nvidia-l4t-bootloader still notifies me that

Reboot is required to complete the installation.

How to get out of this infinite loop?

Flash with 5.1.1 image and run Debian-based OTA to update to 5.1.3.

Thank you. I ran Debian OTA update with

$ sudo vi /etc/apt/sources.list.d/nvidia-l4t-apt-source.list

### add following two lines
deb https://repo.download.nvidia.com/jetson/common r35.5 main
deb https://repo.download.nvidia.com/jetson/t234 r35.5 main

$ sudo apt update
$ sudo apt dist-upgrade

### Reboot the devkit
$ sudo reboot

and successfully upgraded the version to 35.5.0 and everything afterwards works as normal.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.