Nvidia linux driver load error can't change power state from D3cold to D0

And now good news.

Because i could solve problem 2) “additional drivers” surprisingly
by doing a update-initramfs on both systems i’ve gone a step further
in your recomandation.

After initrd hang i tried ctrl+alt+…

In grub-shell no keys are working. I’ve just power-off and reboot into
the old system 5.13.

As my first action i did
sudo journalctl -b8 >mkl_journal1.txt

and so here ist the file.

mkl_journal1.txt (475.3 KB)

And here is a screenshot from the hanging initrd that means from
the grub-shell.

boot_screen_shot_01.jpg.gz (2.1 MB)

As you can see from the journal doing linux and initrd from the grub-shell generate >>NO<< entries for journalctl.

There ars only timestamps
– initrd hangs Feb. 03 after 10:00
– power off
– reboot into 5.13
– reboot into 5.15

For the sake of completeness here comes the journal from within 5.15 system:
mkl_journal_02.txt.gz (58.3 KB)

PS: Location is Germany, Leipzig
Time-Zone Berlin

I found the reason for problem

  1. update-initramfs in the old 5.13 should be
    corrected to use the right file.

Linux Man Pages sayes:


-k version
Set the specific kernel version for whom the initramfs will
be generated. For example the output of uname -r for your
currently running kernel. This argument is optional for update.
>>>> The default is the latest kernel version. <<<<

So only the initial problem remains:

Why stuck initrd after reboot 5.15 if nvidia-xxx-driver ist installed
but comes up without him.

First of: you should not need to play around in grub console. Just select “Alternative configuration” (or whatever it is called), and select the kernel to boot with.

Second: The moment you uninstall the nvidia driver it is de-installed for all kernels! But by default only the current kernels initrd image is updated. So you end up with stale image files and possible mismatch between boot and live driver versions.
update-initramfs -u -k all updates all kernels images.

The journal.txt you posted comes up with the nouveau driver (which also seems to have problems and crashes on shutdown). The nouveau driver should be blacklisted! Usually the nvidia driver installation should take care of that.
This is one way to do it:

So before you reboot with the nvidia drivers installed make sure nouveau is blacklisted and the initrd images are updated.
(grep nouveau /etc/modprobe.d/* /lib/modprobe.d/* - look for a *.conf file with “blacklist nouveau” in it)

Also make sure the nvidia driver has been installed via dkms.
dkms status shows you that.
If the nvidia driver does not show up as “installed” in that output for the kernel you want it to, it won’t load.

sudo dkms install -m nvidia -v <DRIVER_VERSION> -k <KERNEL_VERSION> will install the driver for the specific kernel (of course substitute with the correct version/name).

PS. I still don’t get why you need VmWare to connect to the network, linux is capable of accessing the internet by itself, if correctly configured.

grep nouveau /etc/modprobe.d/* /lib/modprobe.d/*
/etc/modprobe.d/dkms.conf:blacklist nouveau

I had blacklisted nouveau (its now forever) after my answer but initrd hangs.

*** dkms status : the nvidia driver does not show up as “installed

That is i have to remove nvidia after each initrd-hang to be able to boot into 5.15.


I use VmWare for something but accessing the internet thrugh VmWare is for security reason only.

So what does it show???

You can always boot into “recovery mode” for each kernel and run sudo prime-select intel to go with intel only until you fixed things.

uname -r
dkms status
nvidia, 495.46, 5.15.0-18.1-liquorix-amd64, x86_64: installed

This is the output for an prepared 5.15. system to reboot and hang as expected.

Ok, that’s a good idea, i will do so now and give you a new logfile.

After the next try / hang i found your idea with “recovery mode” doesn’t work because the recovery system try to load the same initrd and hangs too.

So I started the old 5.13 wich can’t load nvidia.

Here comes the journal -b 8.

mkl_journal_03.txt.gz (70.9 KB)

*** VmWare

In my VmWare virtual machine there is an ubuntu installed too, you should know.

NOT 8! -b0 is for current boot, -b1 is for last boot. -b8 is worthless.

so this kernel does not load at all, not a nvidia problem.

Sorry, my mistake.

mkl_journal_04.txt.gz (42.2 KB)

*** so this kernel does not load at all, not a nvidia problem

But it occurs only, if the nvidia driver is installed ?

Does it? Well then I don’t know. You still could try the 510 driver.
Also do a sudo apt update and then a sudo apt upgrade -s, maybe there comes a newer 5.13 kernel that works (remove -s flag after you are sure).

Ok, that’s my hope too.

What I was to mention is: the kernel was not involved,
the grub loader didn’t his job.
I know this, because i tried initrd from the grub shell
manualy, and so initrd should have come back to the
commandline and i had have to execute an explicit boot command.
First after this comes the kernel in play.

So I have no solution. What a shame!
I thank you for the many time you sacrificed for
the problem!

As said, don’t use the grub shell… not needed. Use the grub menu to select non default kernels.
If you think something is wrong with grub cfg, update it with sudo initramfs -u -k all and sudo update-grub.

I use the grub menu for non default kernels.
The use of the grub shell was only to see the reaction of each line and to distinguish if initrd command ist the problem or the started kernel.

Please try this:

  • install nvidia driver
  • don’t reboot yet
  • run grep 10de /lib/udev/rules.d/*
  • delete all files that are output
  • run sudo update-initramfs -u
  • add kernel parameter nogpumanager
  • reboot to 5.13 or 5.13 kernel
  • see what happens

Am i right this is a recommendation for using kernel 5.13 and NOT 5.15.0-18.1-liquorix-amd64?