NVIDIA-Linux-x86_64-525.85.05/nvidia-installer segfaults

also NVIDIA-Linux-x86_64-515.57. BOTH since upgrade of OS to “practically same glibc-based OS compiled by different compiler”.

Segfaults after compiling linux-5.11.8 but before installing.

There are countless but reports with same segfault datum so I can’t imagine this has gone on for so long.

WORKED last on: gcc-10.2 / glibc-2.25 (compiled by gcc-4.7.4, an odd build where most things built using 4.7.4 except lk) / linux-5.11.8

BROKEN: gcc-10.2 / glibc-2.25 / linux-5.11.8 (all compiled by 10.2)

(everything seems to work (including Mathematica and mesa), including VESA on same video card and web browser. so blaming 10.2 compile is kinda hard: SEEMS TO BE NVIDIA’S FAULT)

nvidia: loading out-of-tree module taints kernel.
nvidia: module license ‘NVIDIA’ taints kernel
Disabling lock debugging due to kernel taint
BUG: unable to handle page fault for address: 0
#PF: supervisor read access in kernel mode
#PF: error_code(0x0000) - not-present page
CPU: 2 PID: 14427 Comm: nvidia-installe Tainted
RIP: 0010:strcmp+0x2/0x1a

nvidia-uninstall.log: ok

nvidia-installer.log:

appears ok after a forced reboot and rerun with --no-unified-memory (no CUDA and i don’t care about cuda, just Xorg GL and EGL is all i use)

 LD [M]  /usr/src/NVIDIA-Linux-x86_64-525.85.05/kernel/nvidia-peermem.ko
 LD [M]  /usr/src/NVIDIA-Linux-x86_64-525.85.05/kernel/nvidia-drm.ko

make[1]: Leaving directory `/usr/src/linux-5.11.8’
→ done.
→ Kernel module compilation complete.
→ Unable to determine if Secure Boot is enabled: No such file or directory

IDK. I’m stuck. The segfault appears to be in binary nvidia-installer which i obviously cannot fix. I’ve googled it. Forums are marking segfaults as “solved” by forcing users to accept “downgrading OS” as a ‘solution’ .

(yes, proc and tmpfs shm are mounted)

I MIS-MARKED that SOLVED on that old modules worked in both kernels. The below shows the real problem was I added CONFIG_FS_POSIX_ACL to kernel .config and both nvidia and ALSA stopped working, as detailed well in the following: