Nvidia-modeset: ERROR: GPU:0: Idling display engine timed out

Hi,

would like to know if a new workaround exists for the well known bug relative to laptop + sleep mode (S3 state).

Env:

  • FreeBSD-12.1
  • Laptop: DellE6530 (i7_3) feat. a NVS5200M
  • kern.vty = sc (‘vt’ won’t work with nvidia + hybernate in all cases since a long time)

Drivers tested:
compile Option : tried both with and w/o ACPI_PM option

<b>Driver 340.107 : </b>
	hybernate(S3) + resume OK, but Blender2.8 crash due to an OpenGL API bug (shader + textureGather() .. ) ;
<b>Driver 390.87  :</b>
	must use the 'modeset' knl module flavor in order to get modeline w/ NVS5200
	hybernate + resume back NOK lead to: "Nvidia-modeset: ERROR: GPU:0: Idling display engine timed out" ;
	screen stay blank, system still alive, must reboot the system.
	Blender 2.8 OK.
<b>Driver 440.31 :</b> not compatible w/ NVS5200

I tried the workaround from the documentation : running an OpenGL app before hybernate, same result.

Until now, all drivers were Ok with hybernate S3 on my system.
With Blender 2.8, I must use the 390 series if I want to avoid the trouble above.

So :

  • any news on this issue ?
  • optionnaly, could you provide a description and usage of the following nvidia sysctl registries (AFAIK no info in the documentation) :
hw.nvidia.registry.EnableIBMNPURelaxedOrderingMode: 0
hw.nvidia.registry.EnableUserNUMAManagement: 1
hw.nvidia.registry.EnableBacklightHandler: 0
hw.nvidia.registry.EnableStreamMemOPs: 0
hw.nvidia.registry.UseThreadedInterrupts: 1
hw.nvidia.registry.TCEBypassMode: 0
hw.nvidia.registry.IgnoreMMIOCheck: 0
hw.nvidia.registry.MemoryPoolSize: 0
hw.nvidia.registry.EnablePCIeGen3: 0
hw.nvidia.registry.CheckPCIConfigSpace: 4294967295
hw.nvidia.registry.RegisterForACPIEvents: 1
hw.nvidia.registry.MapRegistersEarly: 0
hw.nvidia.registry.EnableMSI: 1
hw.nvidia.registry.UsePageAttributeTable: 4294967295
hw.nvidia.registry.InitializeSystemMemoryAllocations: 1
hw.nvidia.registry.UpdateMemoryTypes: 4294967295
hw.nvidia.registry.DeviceFileMode: 438
hw.nvidia.registry.DeviceFileGID: 0
hw.nvidia.registry.DeviceFileUID: 0
hw.nvidia.registry.ModifyDeviceFiles: 1
hw.nvidia.registry.RmLogonRC: 1
hw.nvidia.registry.ResmanDebugLevel: 4294967295
hw.nvidia.registry.Mobile: 4294967295

Thank you for your help ; and above all, thank you for making NVidia Board alive on FreeBSD.

BR

Val.