NVIDIA MX130 not working on new notebook DELL Vostro 5481 Linux Mint 19.2

Hi All,

I have been dealing with NVIDIA Drivers installation on Linux (Ubuntu based) for years now. I have faced many different problems and tested workarounds, but this time it seems the hardest one.

  • I tried installing drivers (390 and 430 aswell) from synaptic package manager / command line from official repository
  • I tried downloading latest driver from NVIDIA website
  • I tried using nvidia-xconfig query/busid to set the correct PCI busid

but nothing worked out, every time, after installation and reboot no graphic login shows up, I can only log in via tty (CTRL ALT F1).

This is the output of lspci command:

00:00.0 Host bridge: Intel Corporation Device 3e34 (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Device 3ea0
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0b)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Device 9df9 (rev 30)
00:13.0 Serial controller: Intel Corporation Device 9dfc (rev 30)
00:14.0 USB controller: Intel Corporation Device 9ded (rev 30)
00:14.2 RAM memory: Intel Corporation Device 9def (rev 30)
00:14.3 Network controller: Intel Corporation Device 9df0 (rev 30)
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 9de8 (rev 30)
00:15.1 Serial bus controller [0c80]: Intel Corporation Device 9de9 (rev 30)
00:16.0 Communication controller: Intel Corporation Device 9de0 (rev 30)
00:17.0 SATA controller: Intel Corporation Device 9dd3 (rev 30)
00:1c.0 PCI bridge: Intel Corporation Device 9db8 (rev f0)
00:1c.4 PCI bridge: Intel Corporation Device 9dbc (rev f0)
00:1d.0 PCI bridge: Intel Corporation Device 9db0 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Device 9db4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device 9d84 (rev 30)
00:1f.3 Audio device: Intel Corporation Device 9dc8 (rev 30)
00:1f.4 SMBus: Intel Corporation Device 9da3 (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 9da4 (rev 30)
02:00.0 3D controller: NVIDIA Corporation GM108M [GeForce MX130] (rev a2)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
04:00.0 Non-Volatile memory controller: Toshiba America Info Systems Device 0113 (rev 01)

Please let me know what type of debug you may need to help me figure out how to solve this issue.

Please uninstall the .run installer driver using the --uninstall option, then reinstall the driver from official Mint/Ubuntu repo. Also install the package nvidia-prime (sudo apt install nvidia-prime). Delete your /etc/X11/xorg.conf, reboot and make sure that secure boot is disabled in bios. Then run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Perfect, I’ll do it asap and I’ll attach here the bug report gz file.

One last question: which driver should I install from Mint/Ubuntu repo? The latest one (which is nvidia-driver-430 now)?

PS: secure boot is already disabled (needed to do that in order to install the OS alongside Win 10)

Just use the recent 430 driver.

Dear Generix, just following the steps you mentioned solved the problem, it appears that installing nvidia-prime made the difference for me, making it work! Thank you very much.

PS: no /etc/X11/xorg.conf file was present.