Nvidia Nsight Remote Build Issues


I’m in a pickle, and this might be a solved problem, but I’ve gone through stack exchange and the available documentation and can’t seem to find an answer so I am now asking here.

The issue I am having is that I am trying to perform development on a remote GPU system from a local machine. In particular, the local machine is a Linux VM running Ubuntu 18.04. The server is secured so only x11 forwarding through a VPN is allowed for accessing the machine where the code will be run, this machine if it matters is running Centos 7. Both my local Linux VM machine and the remote machine where the CUDA code will be executed have CUDA 10.1.

The issue I am facing is that the code I have inherited is legacy (meaning I can’t redo it) and the only way the makefiles have been managed is through Eclipse running with the Nvidia Nsight eclipse plug-ins. I would otherwise just launch eclipse over ssh with x11 forwarding and edit and build the project makefiles , but the VPN makes this unusable because of response times over the network.

The solution I was hoping to use was to have an edition of Nvidia Nsight Eclipse edition (or regular nsight with the nsight plugins) running on my linux virtual machine and clone the code from a git repo, and then build the project on the remote machine to avoid the problems with x11 through the VPN. I’ve tried now for a while to to do this, but I keep running into issues with the building of the files after going through the available documentation.

(I have so far been able to use RSE to get into the remote machine, I can get local clones of the distribution, and have tried doing target system builds without any luck)