NVIDIA Nsight VSE 2022.3.0.222245 - Legacy Mode not showing up

How to enable Legacy Mode to be able to to debug Maxwell Device (NVIDIA GeForce GTX 960M)?

What version of Visual Studio are you using?

I am using Microsoft Visual Studio Community 2022 (64 bitů) - Current Verze 17.4.3 and NVIDIA GeForce GTX 960M.

Maxwell debugging support was dropped from Visual Studio 2022. Previous versions of Visual Studio should still support Maxwell debugging. See the update list here https://developer.nvidia.com/nsight-visual-studio-edition-2022_1-new-features

I upgraded the Nsight Visual Studio Edition to version 2022.4.0 and the debugger starts to run. The only problem I have now is the Microsoft Visual Studio error:

The Nsight VSE Debugger debugger failed to connect to the ‘[19420] Testloop.exe’ process on the ‘DAN-AS’ machine. Unsupported operation. Unknown error: Ox80004005.

See the same problem Unable to connect to the Microsoft Visual Studio Remote Debugger. Operation not supported. Unknown error: 0x80004005

Finally I moved from VS2022 to VS2017 with following results:

Nsight, Start CUDA Debugging (Legacy)

Do you want to connect without security, OK

Nsight connected John-XX to local host
Nsight disconnected John-XX from local host

Connection to the Nsight monitor on ‘localhost’ failed. Please make sure the monitor is running on the target machine and the security settings match.

My remark: on both sides is default security settings False. When I change it to True, the problem remains the same.

To clarify, you set Enable Secure Connection on both sides to be True? On the monitor side did you add your host machine to Trusted Machines?